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1  Introduction 
This course guide accompanies the Level 2 training sessions in Rhinoceros. This course is geared to 
individuals who will be using and/or supporting Rhino. 

The course explores advanced techniques in modeling to help participants better understand how to 
apply Rhino’s modeling tools in practical situations. 

In class, you will receive information at an accelerated pace. For best results, practice at a Rhino 
workstation between class sessions, and consult your Rhino reference manual for additional 
information.  

Duration: 
3 days 

Prerequisites: 
Completion of Level I training, plus three months experience using Rhino. 

Course Objectives 
In Level 2, you learn how to: 

• Customize toolbars and toolbar collections 

• Create simple macros 

• Use advanced object snaps 

• Use distance and angle constraints with object snaps  

• Construct and modify curves that will be used in surface building using control point editing 
methods 

• Evaluate curves using the curvature graph  
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• Use a range of strategies to build surfaces 

• Rebuild surfaces and curves  

• Control surface curvature continuity 

• Create, manipulate, save and restore custom construction planes 

• Create surfaces and features using custom construction planes  

• Group objects 

• Visualize, evaluate, and analyze models utilizing shading features 

• Place text around an object or on a surface 

• Map planar curves to a surface 

• Create 3-D models from 2-D drawings and scanned images 

• Clean up imported files and export clean files 

• Use rendering tools 



 

Notes: 

Robert McNeel & Associates ❑  5 

Exercise 1—Trackball Mouse (Warm-up) 
1 Begin a new model, save as Trackball.3dm. 

2 Model a trackball mouse on your own. 

 The dimensions are in millimeters. Use the dimensions as guides only. 
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Notes: 

Robert McNeel & Associates ❑  9 

2  Customizing Rhino  

The toolbar layout 
The toolbar layout is the arrangement of toolbars containing command buttons on the screen. The 
toolbar layout is stored in a  file with the .ws3 extension that you can open and save. Rhino comes 
with a default toolbar collection and automatically saves the active toolbar layout before closing unless 
the .ws3 file is read-only. You can create your own custom toolbar collections and save them for later 
use. 

You can have more than one toolbar collection open at a time. This allows greater flexibility to display 
toolbars for particular tasks. 

Rhino’s customization tools make it easy to create and modify toolbars and buttons. Adding to the 
flexibility is the ability to combine commands into macros to accomplish more complex tasks. In 
addition to toolbar customization, it is possible to set up command aliases and shortcut keys to 
accomplish tasks in Rhino. 
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Exercise 2 - Customizing Rhino’s interface 

In this exercise we will create buttons, toolbars, macros, aliases, and shortcut keys that will be 
available to use throughout the class. 

To create a custom toolbar collection: 

1 Open the model ZoomLights.3dm. 

2 From the Tools menu, click Toolbar Layout. 

3 Highlight the Default toolbar collection.  

4 From the Toolbars dialog box File menu, click Save As. 

5 Type Level 2 Training in the File name box, and click Save. 

 A copy of the current default toolbar collection has been saved under the new name. Toolbar 
collections are saved with a .ws3 extension. You will use this new toolbar collection to do some 
customization. 

 
 In the Toolbars dialog box all the open toolbar collections are listed along with a list of all the 

individual toolbars for the selected toolbar collection. Check boxes show the current state of the 
toolbars. A checked box indicates that the toolbar is displayed. 

 
Edit Toolbar Layout 
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To create a new toolbar: 

1 In the Toolbars dialog box, from the Toolbar menu, click New. 

2 In the Toolbars Properties dialog box, name the toolbar Zoom, and click OK. 

 A new single button toolbar appears. 

 

 

 
3 Close the Toolbars dialog box.  

 Another way to work with toolbars is to right-click in the title bar of a floating toolbar. 

 A popup list of toolbar options and commands displays. 
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To edit the new button: 

1 Hold down the Shift key and right-click the blank button in the new toolbar. 

 The Edit Toolbar Button dialog box appears with fields for commands for the left and right 
mouse buttons, as well as for the tooltips. 

2 In the Edit Toolbar Button dialog box, under Tooltips, in the Left box, type Zoom Extents 
except lights. 

3 In the Right box, type Zoom Extents except lights all viewports. 

4 In the Left Mouse Button Command box, type ! SelNone SelLight Invert Zoom Selected 
SelNone 

  
5 In the Right Mouse Button Command box, type ! SelNone SelLight Invert Zoom All 

Selected SelNone 

To change the bitmap image for the button: 

1 In the Edit Toolbar Button dialog box, click the Edit Bitmap button. 

 The bitmap editor is a simple paint program that allows editing of the icon bitmap. It includes a 
grab function for capturing icon sized pieces of the screen, and an import file function. 

 If the bitmap is too large, only a portion of the center is imported. 

2 From the File menu, click Import Bitmap, and select the ZoomNoLights.bmp.  

 You can import any bitmap image of the correct pixel dimensions allowing you to make button 
icons any bitmap images. 
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3 In the Edit Bitmap dialog box, make any changes to the picture, and click OK. 

4 Click OK in the Edit Toolbar Button dialog box. 

  
 To access the new button, click it in the Zoom toolbar or you can link the Zoom toolbar from an 

existing button in another toolbar. 

5 Use the button to zoom the model two ways.  

 You will notice that it ignores the lights when doing a zoom extents. 

 You can enter the commands or command combinations in the appropriate boxes, using these 
rules: 

• A space is interpreted as Enter. Commands do not have spaces (for example, SelLight) but you 
must leave a space between commands  

• If your command string refers to a file, toolbar, layer, object name, or directory for which the path 
includes spaces, the path, toolbar name, or directory location must be enclosed in double-quotes. 

• A ! followed by a space is interpreted as Cancel. Generally it is best to begin a button command 
with ! if you want to cancel any other command which may be running when you click the button. 

• View manipulation commands like Zoom can be run in the middle of other commands. For 
example, you can zoom and pan while picking curves for a loft. Placing the ! in front of these 
commands would not be use the full power of these commands. 
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• User input and screen picks are allowed in a macro by putting the Pause command in the macro. 
Commands that use dialog boxes, such as Revolve, do not accept input to the dialog boxes from 
macros. Use the hyphen form of the command (-Revolve) to suppress the dialog box and control 
it entirely from a macro. 

Note: The rules above also apply to scripts run using the ReadCommandFile command and pasting 
text at the command prompt. More sophisticated scripting is possible with the Rhino Script 
plug-in, but quite a lot can be done with the basic commands and macro rules. Some useful 
commands to are: SelLast, SelPrev, SelName, Group, SetGroupName, SelGroup, Invert, 
SelAll, SelNone, ReadCommandFile, and SetWorkingDirectory. 

To link a toolbar to a button: 

1 Ctrl+right-click the Zoom Extents button in the Standard toolbar.  

2 Under Linked toolbar in the Name list, select Zoom and click OK.  

 Now the Zoom Extents button has a small white triangle in the lower right corner indicating it has 
a linked toolbar. 

  
3 Click and hold the Zoom Extents button to fly out your newly created single button toolbar.  

 If you close the Zoom toolbar you just created, you can always re-open it using the linked button. 

4 Try the new linked button. 

 
Zoom Extents 
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To copy a button from one toolbar to another: 

1 Hold the Ctrl key and move your mouse to the button on the far right of the Standard toolbar.  

 The tooltip indicates that left-click and drag will copy the button and right-click and drag will link 
the button in another toolbar. 

2 Copy the button one space over in the same toolbar.  

3 In the OK to duplicate button dialog box, click OK. 

 

 
4 Hold down the Shift key and right-click on the button you copied to edit the button. 

5 In the Edit Toolbar Button dialog box, under Linked toolbar in the Name list, select Main1.  

6 Delete all the text in the boxes for both left and right mouse button commands. 

7 Under Tooltips, in the Left box, type Main1 Toolbar. 
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8 Click the Edit Bitmap button. 

9 In the Edit Bitmap dialog box, clear the image, then make a simple icon like the example below. 

  
10 Close all the dialog boxes and return to the Rhino window. 

11 Undock the Main toolbar and close it. 

12 Click on the new button that you just made. 

 The Main toolbar flies out instantly and is available. This allows the viewports to be larger than 
when the Main1 toolbar was docked on the side. 

13 Fly out the Main toolbar and tear it off, so it is displayed (floating). 

To add a command to an existing button: 

1 Hold the Shift key and right click the Copy button on the Main1 toolbar.  

2 In the Edit Toolbar Button dialog box, in the Right Mouse Button Command box, type ! Copy 
Pause InPlace  

Copy 
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3 In the Edit Toolbar Button dialog box, in the Right Tooltip box, type Duplicate. 

 This button will allow you to duplicate objects in the same location. We will use this command 
several times during the class. 

  
4 Select one of the objects in the model and right click on the Copy button. 

5 Move the selected object so that you can see the duplicate. 

Command aliases 
The same commands and macros that are available for buttons are also available for command 
aliases. Command aliases are useful productivity features in Rhino. They are commands and macros 
which are activated whenever commands are allowed, but are often used as a keyboard shortcut 
followed by Enter, Spacebar or clicking the right mouse button. 

To make a command alias: 

1 Open the model Aliases.3dm.  

2 From the Tools menu, click Options. 

3 In the Rhino Options dialog box, on the Aliases page, add aliases and command strings or 
macros. 

 The alias is in the left column and the command string or macro is in the right column. The same 
rules apply here as with the buttons. Aliases can be used within other aliases' macros or button 
macros. 

 
Options 

When making aliases, use keys 
that are close to each other or 
repeat the same character 2 or 3 
times, so they will be easy to use. 
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4 Click New to make a new alias. 

 We will make aliases to mirror selected objects vertically and horizontally across the origin of the 
active construction plane. These are handy when making symmetrical objects built centered on 
the origin. 

5 Type mv in alias column. Type Mirror pause 0 1,0,0 in the command macro column. 

6 Click New to make another new alias. 

7 Type mh in alias column. Type Mirror pause 0 0,1,0 in the command macro column.  

  
8 Select some geometry and try the new aliases out. Type mh or mv and press Enter. 

 If no objects are pre-selected, the Pause in the script prompts you to select objects, and a second 
Enter will complete the selection set.  

To import command aliases: 

1 From the Tools menu, click Commands, then click Import Command Aliases. 

2 In the Import Command Aliases dialog box, select Aliases.txt. 

 The alias text file contains alias definitions. 

3 Open the Options dialog box to see the new aliases. 
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Shortcut keys 
The same commands, command strings, and macros that you can use for buttons are also available 
for keyboard shortcuts. Shortcuts are commands and macros that are activated by a function key, 
Ctrl, Alt, and Shift combinations, and an alphanumeric key on the keyboard. 

To make a shortcut key: 

1 From the Tools menu, click Options. 

2 In the Rhino Options dialog box, on the Keyboard page, you can add command strings or 
macros. 

 There are several shortcut keys that already have commands assigned. The same rules apply here 
as with the buttons. 

  
3 Click in the column next to the F4 to make a new shortcut. 

4 Type DisableOsnap Toggle for the shortcut. 

 This shortcut will make it easy to toggle the state of running object snaps. 

5 Close the dialog box and try it out. 
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Plug-ins 
Plug-ins are programs that extend the functionality of Rhino. 

Several plug-ins are included and automatically install with Rhino. Many others are available for 
download from the Rhino website. 

To load a plug-in: 

1 From the Tools menu, click Plug-in Manager. 

2 In the Plug-in Manager dialog box, click Install. 

3 In the Load Plug-In dialog box, click OrientOnCrv.rhp. 

 This plug-in allows you orient an object relative to a curve. 

4 Select the cylinder. 

5 Type OrientOnCrv and press Enter. 

6 At the Base point prompt, snap to the center of the base of the cylinder. 

7 At the Select path curve prompt, select the edge of the spiral. 

8 At the New base point on curve ( Copy=No  Perpendicular=No ) prompt, move the cylinder 
along the curve, and click when you get it positioned. 

 Notice that the cylinder base is aligned to the spiral. 

  

Scripting 
Rhinoceros supports scripting using VBScript.  

To script Rhino, you must have some programming skills. Fortunately, VBScript are simpler to 
program than many other languages, and there are materials available to help you get started. 
VBScript are programming languages developed and supported by Microsoft.  

We will not cover how to write a script in this class, but we will learn how to run a script and apply it 
to a button. 

The following script will make a copy of an object and allow you to place it on another layer in one 
operation. 

 
Plug-in Manger 
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To load a script: 

1 On the command line, type LoadScript and press Enter. 

2 In the Load Script File dialog box, click Add. 

3 In the Open dialog box, select CopyObjectsToLayer.rvb, then click Open. 

4 In the Load RhinoScript dialog box, highlight CopyObjectsToLayer.rvb, then click Load. 

  
5 At the Select Objects prompt, pick the cylinder, and press Enter. 

6 In the Copy Objects to Layer dialog box, click Layer 01 and then click OK. 

  

To edit the script file: 

1 On the command line, type LoadScript and press Enter. 

2 In the Load RhinoScript dialog box, highlight CopyObjectsToLayer.rvb, then click Edit. 

 The last line of the script runs the script. Since we are going to make a button to run the script 
after it is loaded, you should delete this line. 

3 Delete the last line in the script, then close the editor and save the changes. 

4 Close the Load RhinoScript dialog box. 
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To make a button that will load or run a script: 

1 From the Tools menu, click Toolbar Layout. 

2 In the Toolbars dialog box, check Layer and highlight it. 

3 In the Toolbars dialog box, from the Toolbar menu, click Add Button, then close the Toolbars 
dialog box. 

4 To edit the new button, hold down the Shift key and right-click on the new button that appeared 
in the Layer toolbar. 

5 In the Edit Toolbar Button dialog box, in the Left Tooltip, type Copy Objects to Layer. 

6 In the Right Tooltip, type Load Copy Objects to Layer Script. 

7 In the Left Mouse Button Command box, type ! RunScript /rvb /CopyObjectsToLayer. 

8 In the Right Mouse Button Command box, type ! LoadScript /CopyObjectsToLayer.rvb. 

9 In the Edit Toolbar Button dialog box, click Edit Bitmap. 

10 In the Edit Bitmap dialog box, from the File menu, click Import, and Open the 
CopyObjectsToLayer.bmp, then click OK. 

11 In the Edit Toolbar Button dialog box, click OK. 

12 Try the new button. 

Template files 
A template is a Rhino model file you can use to store basic settings. Templates include all the 
information that is stored in a Rhino 3DM file: objects, grid settings, viewport layout, layers, units, 
tolerances, render settings, dimension settings, notes, etc.  

You can use the default templates that are installed with Rhino or save your own templates to base 
future models on. You will likely want to have templates with specific characteristics needed for 
particular types of model building. 

The standard templates that come with Rhino have different viewport layouts or unit settings, but no 
geometry, and default settings for everything else. Different projects may require other settings to be 
changed. You can have templates with different settings for anything that can be saved in a model file, 
including render mesh, angle tolerance, named layers, lights, and standard pre-built geometry. 

The New command begins a new model with a template (optional). It will use the default template 
unless you change it to one of the other templates or to any other Rhino model file. 

The SaveAsTemplate command creates a new template file.  

To change the template that opens by default when Rhino starts up, choose New and select the 
template file you would like to have start when Rhino starts, then check the Use this file when 
Rhino starts box. 
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To create a template: 

1 Start a new model. 

2 Select the Inches.3dm file as the template. 

3 From the Render menu, click Current Renderer, then click Flamingo Raytrace. 

4 From the File menu, click Properties. 

5 In the Document Properties dialog box, on the Grid page, change the Grid Snap spacing 
to .1, the Minor gridlines every to 1, the Major lines every to 10, and the Grid extents 
to 10. 
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6 On the Mesh page change the setting to Smooth and slower. 
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7 On the Units page change the Absolute tolerance to 0.001. 
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8 On the Flamingo page, check Use lights on layers that are off. 

9 On the Flamingo page click Environment, check Ground plane and accept the default material. 
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10 In the Environment dialog box, on the Main page, check Background image.  

11 On the Background image page, select Jeff’sSunroom.bmp for the background, under the 
Projection dropdown select Spherical.  

  
12 Click OK to close the Environment dialog box.  

13 Click OK to close the Document Properties dialog box. 

14 With the Perspective viewport active, press F7 to toggle the grid off. 
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15 Open the Layers dialog box and rename Layer 05 to Lights, Layer 04 to Curves, and Layer 03 
to Surfaces.  

 Make the Lights layer current.  

 Delete Default, Layer 01 and Layer 02 layers.  

 Close the dialog box. 

  
16 Set up two spotlights so that they point at the origin and are approximately 45 degrees from the 

center and tilted 45 degrees from the construction plane. 

  
17 To make the Curves layer the only visible layer, from the Edit menu, click Layers, then click One 

Layer On. 

18 From the File menu, click Save As Template and navigate to the templates directory.  

 Name the template Inches_SmallProduct_001.3dm. 

 This file with all of its settings is now available any time you start a new model. You should make 
custom templates for the kind of modeling that you do regularly to save set up time. 

 
One Layer ON 
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To set a default template: 

1 From the File menu, click New. 

2 Select the template you want to use as the default template. 

3 In the Template File dialog box, check the Use this file when Rhino starts checkbox. 
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3  NURBS Topology  
 

NURBS surfaces always have a rectangular topology. Rows of surface points and parameterization are 
organized in two directions, basically crosswise to each other. This is not always obvious when 
creating or manipulating a surface. Remembering this structure is useful in deciding which strategies 
to use when creating or editing geometry. 

Exercise 3 - Topology 
 This exercise will demonstrate how NURBS topology is organized and discuss some special cases 

that need to be considered when creating or editing geometry. 

1 Open the model Topology.3dm. 

 There are several surfaces and curves visible on the current layer. 

2 Turn on the control points of the simple rectangular plane on the left. 

 It has four control points, one at each corner—this is a simple untrimmed planar surface that 
shows the rectangular topology. 

3 Now turn on the control points of the second, more curvy surface. 

 There are many more points, but it is clear that they are arranged in a rectangular fashion. 

4 Now select the cylinder. 

 It appears as a continuous circular surface, but it also has a rectangular boundary. 

 
Control Points On 



 

Notes: 

Robert McNeel & Associates ❑  32 

5 Use the ShowEdges command (Analyze menu: Edge Tools > click Show Edges) to highlight the 
surface edges. 

  
 Notice that there is a seam highlighted on the cylinder. The seam that is highlighted represents 

two edges of the rectangle, while the other two edges are circular at the top and the bottom. The 
rectangular topology is present here, also. 

6 Now select the sphere. 

 It appears as a closed continuous object, but it also has a rectangular boundary. 

7 Use the ShowEdges command to highlight the edges. 

  
 Notice that there is a seam highlighted on the sphere. The seam that is highlighted represents two 

edges of the rectangle, while the other two edges are collapsed to a single point at the poles. The 
rectangular topology is present here, also, though very distorted. 

 When all of the points of an untrimmed edge are collapsed into a single point, it is called a 
singularity.  A singularity is a special case, but as a general rule it is better not to stack one control 
point on top of another. If internal points of an edge are collapsed or stacked into a single point, 
Rhino gives an error message with the Check or SelBadObjects commands. 

8 With the sphere selected, press F11 followed by F10.  

 The control points of the first two surfaces have been turned off (F11) and those of the sphere 
have been turned on (F10). 

9 With the Point object snap on, Zoom Target very tight in on one of the poles of the sphere. 

10 Press F11 to turn off the points. 

11 Select the sphere. 

12 Start the Smooth (Transform menu: Smooth) command. 

 
Show Edges 

 
Zoom Target  
(right mouse button option) 

 
Smooth 
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13 In the Smooth dialog box, uncheck Smooth Z, then click OK. 

 A hole appears at the poles of the sphere. 

  
 ShowEdges will highlight this as an edge as well.  

14 Use the Home key to Zoom back out. 

 This is the fastest way to step back through view changes. 

To select points: 

1 Open the Select Points toolbar. 

  
2 Turn on the points for the sphere. 

3 Select a single point at random on the sphere. 

4 From the toolbar, click Select U. 

 An entire row of points is selected.  

5 Clear the selection by clicking in an empty area and select another point on the sphere. 

6 From the toolbar, click Select V. 

 A row of points in the other direction of the rectangle is selected. This arrangement into U and V 
directions is always the case in NURBS surfaces. 

7 Try the other buttons in this toolbar on your own. 

 
Select U 

 
Select V 
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Exercise 4—Trimmed NURBS 
1 Open the model Trimmed NURBS.3dm. 

 This surface has been trimmed out of a much larger surface. The underlying four sided surface 
data is still available after a surface has been trimmed, but it is limited by the trim curves (edges) 
on the surface. 

2 Select the surface and turn on the control points. 

 Control points can be manipulated on the trimmed part of the surface or the rest of the surface, 
but notice that the trimming edges also move around as the underlying surface changes. The trim 
curve always stays on the surface. 

 

To remove the trims from a surface: 

1 Start the Untrim (Surface menu: Surface Edit Tools > Untrim) command. 

2 At the Select boundary to detach prompt, select the edge of the surface. 

 The original underlying surface appears and the trim boundary disappears. 

  
3 Use the Undo command to return to the previous trimmed surface. 

 
Untrim 
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To detach a trimming curve from a surface: 

1 Start the Untrim command with the KeepTrimObjects option set to Yes (Surface menu: Surface 
Edit Tools > Detach Trim). 

2 At the Select boundary to detach prompt, select the edge of the surface. 

 The original underlying surface appears. The boundary edges are converted to curves, which are 
no longer associated with the surface. 

  
3 Undo to return to the previous trimmed surface. 

To shrink a trimmed surface: 

1 Start the ShrinkTrimmedSrf command (Surface menu: Surface Edit Tools > Shrink Trimmed 
Surface). 

2 At the Select trimmed surfaces to shrink prompt, select the surface and press Enter to end 
the command. 

 The underlying untrimmed surface is replaced by a one with a smaller range that matches the old 
surface exactly in that range. You will see no visible change in the trimmed surface. Only the 
underlying untrimmed surface is altered. 

  

 
Detach Trim 

 
Undo 

 
Shrink Trimmed Surface 
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4  Curve Creation  
 

We will begin this part of the course by reviewing a few concepts and techniques related to NURBS 
curves that will simplify the learning process during the rest of the class. Curve building techniques 
have a significant effect on the surfaces that you build from them. 

Curve degree 
The degree of a curve is related to the extent of the influence a single control point has over the 
length of the curve. 

For higher degree curves, the influence of any single point is less in a specific part of the curve but 
affects a longer portion of the curve.  

In the example below, the five curves have their control points at the same six points. Each curve has 
a different degree. The degree can be set with the Degree option in the Curve command. 

Exercise 5—Curve Degree 
1 Open the model Curve Degree.3dm. 

2 Use the Curve command (Curve menu: Free-Form > Control Points) with Degree set to 1, using 
the Point object snap to snap to each of the points. 

  

 
Curve 
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3 Use the Curve command with Degree set to 2, using the Point object snap to snap to each of 
the points. 

  
4 Use the Curve command with Degree set to 3, using the Point object snap to snap to each of 

the points. 

  
5 Use the Curve command with Degree set to 4, using the Point object snap to snap to each of 

the points. 

  
6 Use the Curve command with Degree set to 5, using the Point object snap to snap to each of 

the points. 

  



 

Notes: 

Robert McNeel & Associates ❑  39 

7 Use the CurvatureGraphOn command (Analyze menu: Curve > Curvature Graph On) to turn on 
the curvature graph for one of the curves. The graph indicates the curvature continuity and the 
rate of change in the curve. 

 Degree 1 curves have no curvature. Degree 2 curves have continuous tangency. Degree 3 curves 
have continuous curvature. In Degree 4 curves, the rate of change of curvature is continuous. In 
Degree 5, the rate of change of the rate of change is continuous. 

 

 

  
8 View the curvature graph as you drag some control points.  

 Note the change in the curvature hairs as you move points. 

9 Repeat this process for each of the curves. 

 
Curvature Graph On 
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Curve and surface continuity 
Since creating a good surface so often depends upon the quality of the input curves, it is worthwhile 
investigating some of the characteristics of both. 

For most curve building and surface building purposes we can talk about four useful levels of 
continuity: 

Not continuous 

The curves or surfaces do not meet at their end points or edges. Where there is no continuity, 
the objects cannot be joined. 

  

Positional continuity (G0) 

Curves meet at their end points, surfaces meet at their edges. 

  

Positional continuity means that there is a kink at the point where two curves meet. The curves 
can be joined in Rhino into a single curve but there will be a kink and the curve can still be 
exploded into at least two sub-curves. Similarly two surfaces may meet along a common edge 
but will show a kink or seam, a hard line between the surfaces. For practical purposes, only the 
end points of a curve or the last row of points along an edge of an untrimmed surface need to 
match to determine G0 continuity. 
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Tangency continuity (G1) 

Curves or surfaces meet and the directions of the tangents at the endpoints or edges is the 
same. You should not see a crease or a sharp edge. 

  

Tangency continuity means that there is no kink between curves or surfaces but rather a smooth 
transition. The clearest example of G1 continuity is a radial fillet between curves or surfaces. In 
tangency continuity the end control point and the next control point on a curve, or the edge row 
and the next row of points of a surface determine the tangency condition. 

Curvature continuity (G2) 

Curves or surfaces meet, their tangent directions are the same and the radius of curvature is the 
same for each at the end point. 

  

Curvature continuity  is the smoothest of the cases we are considering. It means that the surface 
or curve changes more smoothly than with tangency continuity. There is no abrupt change in 
direction from one curvature to the next. In G1 continuity the curvature changes at a single 
point. For example, the transition from a straight line to a tangent arc takes place at a given 
point. With G2 continuity this change happens over a distance in the curves, so that curves and 
surfaces tend to have a more smooth (organic) and less mechanical look to them. Many product 
designs make use of G2 continuity. 

Note: There are higher levels of continuity possible. For example, G3 continuity means that not only 
are the conditions for G2 continuity met, but also that the rate of change of the curvature is 
the same on both curves or surfaces at the common end points or edges. G4 means that the 
rate of change of the rate of change is the same. Rhino has tools to build such curves and 
surfaces, but fewer tools for checking and verifying such continuity than for G0-G2. 
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Exercise 6 - Geometric Continuity 
1 Open the model Curve Continuity.3dm. 

 The two curves are clearly not tangent. Verify this with the continuity checking command GCon.  

2 Start the GCon command (Analyze menu: Curve > Geometric Continuity). 

3 Click near the common ends (1 and 2) of each curve. 

  
 Rhino displays a message on the command line indicating the curves are not touching at the ends. 

 Curve end difference = 0.0304413  
Tangent difference in degrees = 10.2772 
Radius of curvature difference = 126.531 
Curvature direction difference in degrees = 10.2772 
Curve ends are out of tolerance. 

To make the curves have position continuity: 

1 Turn on the control points for both curves and zoom in on the common ends. 

2 Turn on the Point object snap and drag one of the end points onto the other. 

  

 
Geometric Continuity 
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3 Repeat the GCon command. 

 The command line message is different now:  

 Curve end difference = 0  
Tangent difference in degrees = 10.3069 
Radius of curvature difference = 126.771 
Curvature direction difference in degrees = 10.3069 
Curves are G0. 

4 Undo the previous operation. 

5 Start the Match command (Curve menu: Curve Edit Tools > Match). 

6 At the Select open curve to change - pick near end prompt, pick near the common end of one 
of the curves. 

7 At the Select open curve to match - pick near end ( SurfaceEdge ) prompt, pick near the 
common end of the other curve. 

8 In the Match Curve dialog box, check Position, Average Curves, and Preserve other end. 

  
9 Repeat the GCon command. 

 The command line message indicates:  

 Curve end difference = 0  
Tangent difference in degrees = 10.2647 
Radius of curvature difference = 126.708 
Curvature direction difference in degrees = 10.2647 
Curves are G0. 

 
Match 
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Exercise 7 - Tangent Continuity 

In this part of the exercise, we will make the two curves have G1 continuity. G1 continuity is 
determined by the end points and the second points of the curves. These two points determine the 
tangent direction of the end of a curve and since G1 continuity requires that the tangent direction be 
the same for both curves, it is sufficient to have the two last points on each curve, four all together, 
fall in line with each other. The two end points must be in the same place and the next control point 
on each curve must fall in a line with those end points. This can be done by manipulating the points 
directly or by using the Match command. 

We will use Move, SetPt, Zoom Target, PointsOn (F10), PointsOff (F11) and the object snaps 
End, Point, Along, Between and the Tab lock to accomplish this. 

First, we will create some aliases that will be used in this exercise. 

To make Along and Between aliases: 

Along and Between are one-time object snaps that are available in the Tools menu under Object 
snaps. They can only be used after a command has been started and apply to one pick. We will create 
new aliases for these object snaps. 

1 In the Rhino Options dialog box on the Aliases page click the New button, and then type a in 
the Alias column and Along in the Command macro column. 

2 Type b in the Alias column, and Between in the Command macro column.  

 
Along 

 
Between 
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3 Close the Rhino Options dialog box. 

  

To change the continuity by adjusting control points using the Between object snap: 

1 Use the OneLayerOn command to turn on only the Curves 3d layer.  

2 Check the continuity of the curves with the GCon command.  

3 Turn on the control points for both curves. 

4 Window select the common end points of both curves (1). 

5 Use the Move command (Transform menu: Move) to move the points. 

6 At the Point to move from ( Vertical ) prompt, snap to the same point (1). 

  

 
One Layer ON 

 
Move 
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7 At the Point to move to prompt, type b and press Enter to use the Between object snap. 

8 At the First point prompt, select the second point (2) on one curve. 

9 At the Second point prompt, select the second point (3) on the other curve. 

  
 The common points are moved in between the two second points, aligning the four points.  

10 Check the continuity. 

To change the continuity by adjusting control points using the Along object snap: 

1 Undo the previous operation. 

2 Select one of the second points (2 or 3). 

3 Use the Move command (Transform menu: Move) to move the point. 

4 At the Point to move from ( Vertical ) prompt, snap to the point (2 or 3). 

  
5 At the Point to move to prompt, type a and press Enter to use the Along object snap. 

6 At the Start of tracking line prompt, snap to the second point (3 or 2) on the other curve. 
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7 At the End of tracking line prompt, snap to the common points (1). 

  
 The point tracks along a line that goes through the two points, aligning the four points. Click to 

place the point. 

8 Check the continuity. 

 G1 continuity can be maintained by making sure that any point manipulation of the critical four 
points takes place along the line on which they all fall. 

 Once you have G1 continuity you can still edit the curves near their ends without losing continuity. 

To edit the curves without losing continuity: 

1 Select the end points or either of the second points on the curves. 

  
2 Turn on the Point object snap only and drag (or Move) the point to another of the four tangency 

points. 
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3 When the point is dragged or moved over the next point and the object snap flag appears, do not 
click; instead press and release the Tab key and then continue dragging. 

  
 The movement of the point is now constrained to the line between the original location and the 

point in space where the tab key was pressed ensuring that G1 continuity is maintained. 

 Pressing the Tab key again before finally placing the point would release the Tab direction lock, 
losing the guarantee of continuity. 

4 Press the left mouse button to place the point. 

Exercise 8 - Curvature Continuity 

Curvature continuity (G2) is more complicated, because it involves the last three points on a curve. 
Their arrangement is only in a straight line like G1 continuity when the curve being matched is a 
straight line or has no curvature at the end.  

Maintaining G2 continuity when directly manipulating points is more complicated than it is for G1.  

For establishing G2 continuity the Match command must be used.  

To match the curves: 

1 Turn on the 3D curve layer and make it current. 

2 Turn off the 2D curve layer. 

3 Use the Match command (Curve menu: Curve Edit Tools > Match) to match the magenta (1) 
curve to the red (2) curve. 

 
 

 
Match Surface 
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 When you use Match with Curvature checked on these particular curves, the third point on the 
curve to be changed is constrained to a position calculated by Rhino to establish the desired 
continuity. 

  
 The curve being changed is significantly altered in shape. Moving the third point by hand will break 

the G2 continuity at the ends, though G1 will be maintained. 

Advanced techniques for controlling continuity 
There are two additional methods to edit curves while maintaining continuity in Rhino. (1) The 
EndBulge command allows the curve to be edited while maintaining continuity. (2) Adding knots will 
allow more flexibility when changing the curve's shape.  

To edit the curve with end bulge 

1 Right click on the Copy button to make a duplicate of the magenta curve and then Lock it. 

2 Start the EndBulge command (Edit menu: Adjust End Bulge). 

3 At the Select curve or surface to adjust prompt, select the red curve. 

  

Note: The EndBulge command converts any curve that has fewer than six control points to a degree 
5 curve with six control points. 

 
Adjust End Bulge 
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4 At the Select point to move ( PreserveCurvature=Yes ) prompt, select the third point and drag it 
and click to place the point, and the press Enter to end the command. 

 The G2 continuity is preserved. 

  

To add a knot: 

 Adding a knot or two to the curve will put more points near the end so that the third point can be 
nearer the end. Knots are added to curves and surfaces with the InsertKnot command. 

1 Undo your previous adjustments. 

2 Start the InsertKnot command (Edit menu: Control Points > Insert Knot). 

3 At the Select curve or surface for knot insertion prompt, select the red curve. 

4 At the Point on curve to add knot ( Automatic  Symmetrical=No ) prompt, pick a location on the 
curve to add a knot in between the first two points. 

  

 
Insert Knot 
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5 Match the curves after inserting a knot into the red curve.  

 In general a better behaved curve will result if the new knots are placed roughly halfway between 
existing knots, which are highlighted during the InsertKnot command. 

  

 





 

Notes: 

Robert McNeel & Associates ❑  53 

5  Surface Continuity  
 

The continuity characteristics for curves can also be also applied to surfaces. Instead of dealing with 
the end point, second, and third points, entire rows of points at the edge, and the next two positions 
away from the edge are involved. The tools for checking continuity between surfaces are different 
from the simple GCon command. 

Analyze surface continuity 
Rhino takes advantage of the OpenGL display capability to create false color displays for checking 
curvature and continuity within and between surfaces. These tools are located in the Analyze menu, 
under Surface. The tool which most directly measures G0-G2 continuity between surfaces is the 
Zebra command. Zebra analysis simulates reflection of a stripped background on the surface. 

Note: An OpenGL graphics accelerator card is not necessary to use these tools, although they may 
work faster with OpenGL acceleration.  
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Exercise 9 - Surface Continuity 
1 Open the model Surface Continuity.3dm. 

2 Turn on points on both surfaces. 

  

To check the continuity between the surfaces using Zebra analysis: 

1 Start the Zebra command (Analyze menu: Surface > Zebra). 

 The surfaces are colored by stripes. 

 
2 Close the Zebra Options window. 

3 Start the MatchSrf command (Surface menu: Surface Edit Tools > Match). 

4 At the Select untrimmed surface edge to change prompt, select the edge of the red surface 
nearest the black surface. 

5 At the Select target surface edge prompt, select the edge of the black surface nearest the red 
surface. 

 

 
Zebra 

 
Match Surface 
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6 In the Match Surface dialog box, choose Position as the desired continuity.  

 Make sure Average is unchecked and Preserve opposite end is checked. 

 Click OK. 

  
 The edge of the red surface is pulled over to match the edge of the black one. 

  
7 Join the surfaces. 

8 Check the polysurface with Zebra analysis.  

 There is no particular correlation between the stripes on one surface and the other except that 
they touch. This indicates G0 continuity. 
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9 Explode the polysurface, and use the MatchSrf command (Surface menu: Surface Edit Tools > 
Match) again with the Tangency option. 

 When you pick the edge to match you will get direction arrows that indicate which surface edge is 
being selected. The surface that the direction arrows are pointing toward is the surface whose 
edge is selected. 

  
10 Join the surfaces and check the results with Zebra analysis. 

11 Adjust the controls in the Zebra Options window so that the stripes are thinner and alternate the 
direction between vertical and horizontal to get the most informative display. 

 This time there is a correlation between the surfaces. If the stripes are chunky and angled over 
the surface, use the Adjust mesh button to make a finer mesh setting for the display. The ends of 
the stripes on each surface meet the ends on the other cleanly though at an angle. This indicates 
G1 continuity. 

  
12 Explode the polysurface, and use the MatchSrf command (Surface menu: Surface Edit Tools > 

Match) with the Curvature option. 
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13 Join the surfaces and check the results with Zebra analysis. 

 The stripes now align themselves smoothly across the seam. Each stripe connects smoothly to the 
counterpart on the other surface. This indicates Curvature (G2) continuity. 

  

Note: Doing these operations one after the other may yield different results than going straight to 
Curvature without first using position. This is because each operation changes the surface near 
the edge, so the next operation has a different starting surface. 

Add knots to control surface matching 
As in matching curves, MatchSrf will sometimes distort the surfaces more than is acceptable in order 
to attain the desired continuity. We will add knots to surfaces to limit the influence of the MatchSrf 
operation. The new second and third rows of points will be closer to the edge of the surface. 

Surfaces can also be adjusted with the EndBulge command. 

To add a knot to a surface: 

1 Undo the previous operation. 

2 Use the InsertKnot command to insert a row of knots near each end of the red surface.  

 When this command is used on a surface, it has more options. You can choose to insert a row of 
knots in the U-direction, the V-direction, or both.  

 Choose Symmetrical to add knots at opposite ends of a surface. 
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3 Use MatchSrf to match the surface to the other. 

  

To adjust the surface using end bulge: 

1 Start the EndBulge command (Edit menu: Adjust End Bulge). 

2 At the Select curve or surface edge to adjust prompt, pick the edge of the red surface. 

3 At the Point to edit prompt, pick a point on the edge at which the actual adjustment will be 
controlled. 

  
4 At the Start of range to edit prompt, pick a point along the common edges to define the region 

to be adjusted. 

  

 
Adjust Surface End Bulge 
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5 At the End of range to edit prompt, pick another point to define the region to be adjusted. 

  
 The influence of the adjustment will fade to zero at each end of the region you define. 

Construction geometry may be useful here for snapping an exact region if necessary. If the whole 
edge is to be adjusted equally, simply press Enter.  

 Rhino shows three sets of points on each curve, of which you are allowed to manipulate only two. 
Of these two, notice that Rhino also moves the point that is not being directly manipulated in 
order to maintain the continuity. If maintaining the G2 curvature-matching condition at the edge is 
not needed, use the PreserveCurvature option to turn off one of the two points available for 
editing. Only G1 will be preserved. 

6 At the Select point to move ( PreserveCurvature=Yes ) prompt, select a point. 

7 At the Pick new point location ( PreserveCurvature=Yes ) prompt, drag the point and click. 

  
8 Press Enter to end the command. 
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Commands that use continuity 
Rhino has several commands that that can build surfaces using the edges of other surfaces as input 
curves. They can build the surfaces with G1 or G2 continuity to those neighboring surfaces. The 
commands are: 

• NetworkSrf 

• Sweep2  

• Patch (G1 only) 

• Loft (G1 only) 

• Blend (G1 or G2) 

The following exercises will provide a quick overview of these commands. 

Exercise 10—Continuity Commands 

To create a surface from a network of curves: 

1 Open the model Continuity Commands.3dm. 

 On the Surfaces layer there are two joined surfaces which have been trimmed leaving a gap. This 
gap needs to be closed up with continuity to the surrounding surfaces. 

2 Turn on the Network layer.  

 There are several curves already in place which define the required cross sections of the surface. 
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3 Use the NetworkSrf command (Surface menu: Curve Network) to close the hole with an 
untrimmed surface using the curves and the edges of the surfaces as input curves. 

 The NetworkSrf dialog box allows you to specify the desired continuity on edge curves which 
have been selected. 

 Note that there is a maximum of four edge curves as input. You can also specify the tolerances or 
maximum deviation of the surface from the input curves. By default the edge tolerances are the 
same as the model's Absolute Tolerance setting. The interior curves' tolerance is set 10 times 
looser than that by default.  

 

 

4 Change the Interior curves settings to 0.01. Choose Curvature continuity for all the edges. 

 The surface that is created has curvature continuity on all four edges. 

  
5 Check the resulting surface with Zebra analysis. 

  

 
Surface from Curve Network 
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To make the surface with a two-rail sweep: 

1 Use the OneLayerOn command to open the Surfaces layer by itself again and then left click in 
the layers panel of the status bar and select the Sweep2 layer. 

2 Start the Sweep2 command (Surface menu: Sweep 2 Rails) and select the long surface edges as 
the rails. 

  
3 Select one short edge, the cross-section curves and the other short edge as profiles. 

  
 Since the rails are surface edges, the display labels the edges, and the Sweep 2 Rails Options 

dialog box gives the option of maintaining continuity at these edges.  

4 Choose Curvature for both Rail curve options. 

 

 

 
Sweep along 2 Rails 
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5 Check the resulting untrimmed surface with Zebra analysis. 

  

To make a patch surface: 

 The Patch command builds a trimmed surface, if the bounding curves form a closed loop, and can 
match continuity to G1 if the bounding curves are edges. 

1 Turn on the Surfaces, and Patch layers.  

 Turn all other layers off. 

2 Start the Patch command (Surface menu: Patch). 

3 Select the edge curves and the interior curves, and then press Enter. 

 
Patch 
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4 In the Patch Options dialog box, set the following options 

 Set Sample point spacing to 1.0 

 Set Stiffness to .01 

 Set Surface U and V spans to 10 

 Check Adjust tangency and Automatic trim, then click OK. 

 The finished surface does not appear to be very smooth. There are a number of settings available 
for adjusting the surface accuracy. We will make some changes and repeat the command. 

 

 

5 Undo the previous operation. 

6 Use the Patch command and select the same edges and curves. 

7 In the Patch Options dialog box, change the Surface U and V spans to 17, then click OK. 

 The finished surface appears has more isocurves but isn’t much smoother. 
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8 Undo the previous operation. 

9 Use the Patch command and select the same edges and curves. 

10 In the Patch Options dialog box, change the Sample point spacing to .01, the Stiffness to 
1.0, then click OK.  

 The finished surface appears smoother. 

 

 

11 Join the surfaces. 

12 Use the ShowEdges command (Analyze menu: Edge Tools > Show Edges) to display the naked 
(unjoined) edges. 

 There is a naked edge between the patch and the polysurface.  

 You can join the naked edges for meshing or rendering purposes. 

  

Why can’t I join the edges using 
Join 2 Naked Edges? 
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13 Undo the patch surface and remake it with more isocurves. 

14 Continue to work with this until it joins without naked edges. 

15 Check the results with Zebra analysis. 

  

To make a lofted surface: 

 The Loft command also has built in options for surface continuity. 

1 Open the model Loft and Blend.3dm. 

2 Start the Loft command (Surface menu: Loft). 

3 At the Select curves to loft ( Point ) prompt, select the top edge curve, the two curves, and then 
the bottom edge curve. 

  
4 Press Enter when done. 

 
Loft 
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5 In the Loft Options dialog box under Style, select Normal 

 Check Match start tangent, Match end tangent, and Do not simplify. 

   
 The new surface has G1 continuity to the original surfaces. 

  

To make a surface blend: 

 The last command can control continuity with adjoining surfaces is BlendSrf. 

1 Undo the loft. 

2 Start the BlendSrf command (Surface menu: Blend Surface), in the command line options, set 
Continuity=curvature. 

3 Select an edge and press Enter, then select the other edge and press Enter. 

 The curve edges at each are highlighted and the Blend Bulge dialog box opens. 

 

 

 
Blend Surface 
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 There is an option to add more sections when the dialog box is displayed. 

4 Adjust the bulge if desired, then click OK. 

5 Check the results with Zebra analysis. 

  

Additional surfacing techniques 
There are several methods for making surface transitions. In this exercise we will discuss a variety of 
ways to fill holes and make transitions using the NetworkSrf, Loft, Sweep1, Sweep2, Blend, Fillet 
and Patch commands. 

Fillets and Corners 
While Rhino has automated functions for making fillets, there are several situations that take manual 
techniques. In this section, we will discuss making corners with different fillet radii, variable radius 
fillets and blends, and fillet transitions. 

Exercise 11—Fillets and Blends 

To make a corner fillet with 3 different radii and a curve network: 

1 Open the model Corner Fillet.3dm. 

2 Use the FilletEdge command (Solid menu: Fillet Edge) to fillet edge (1) with a radius of 5, edge 
(2) with a radius of 3, and edge (3) with a radius of 2. 

  

 
Fillet Edge 
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3 Start the ExtractSrf command (Solid menu: Extract Surface), then select the 3 fillets and the 
front surface, the press Enter to end the command. 

  
4 Use the Blend command (Curve menu: Blend Curves), to create curves between the edge curves 

of the smaller fillet surfaces. 

  

Note: The blend curves will not actually touch the fillet surface precisely. The blend curve is not an 
arc like the fillet surface cross-section. You may have to pull the curve to the surface before 
trimming or use the Split command. 

5 Use the Pull command (Curve menu: Curve from objects > Pullback) to pull the right-hand blend 
curve to the fillet surface. 

6 Use the Trim command to trim the surfaces with the blend and the pull curve. 

  
7 Use the NetworkSrf command (Surface menu: Curve Network) to fill the hole. 

 
Extract Surface 
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8 At the Select curves in network ( NoAutoSort ) prompt, select the edge curves. 

  
9 At the Select curves in network ( NoAutoSort ) prompt, press Enter. 

10 In the Surface From Curve Network dialog box, select Tangency for all four edges. 

 

11 Join the surfaces and check the polysurface for naked edges. 
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To make a variable radius fillet: 

1 Open the model Sandal Sole.3dm. 

2 Use the Circle command with the AroundCurve option to create circles of different radius around 
the bottom edge of the sole. 

 
3 Use the SelLayer command (Edit menu: Select Objects > By Layer...) to select the curve and the 

circles. 

4 Start the Sweep1 command (Surface menu: Sweep 1 Rail) to make a variable radius pipe around 
the edge. 

5 In the Sweep 1 Rail Options dialog box, check Rebuild with 8 control points and Closed 
sweep, and then click OK. 

 If you do not rebuild the surface, it can become quite complex. Another option to simplify the 
swept surface is to align the seam of each circle to the same knot point on each cross-section.  

 

 

 
Circle: Around Curve 

 
Select Layers 

 
Sweep along 1 Rail 
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6 Unlock the Shoe Bottom layer. 

7 Trim the sidewall and the bottom with the swept surface. 

   
8 Turn off the Curve Layer and change to the Fillet layer.  

Note: You may have to merge the edges (Analyze menu: Edge Tools > Merge Edge) of the trimmed 
surfaces before you blend. It helps to hide the other surfaces while you merge the edges. 

9 Use the BlendSrf command (Surface menu: Blend Surface) to make the variable fillet. 

 

10 Join the surfaces. 

 

 
Merge Edge 

 
Blend Surface 
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To make a six-way fillet using a patch: 

1 Open the model Fillet Edge.3dm. 

  
2 Use the FilletEdge command (Solid menu: Fillet Edge), with Radius=1, to fillet all the joined 

edges at the same time. 

    
3 Use the Patch command (Surface menu: Patch) to fill in the opening at the center. 

4 Select all six edges to define the patch. 

5 In the Patch Options dialog box, check Adjust Tangency and Automatic Trim. Change the 
Surface U and V Spans to 10, and the Stiffness to 10. 

 

When the area to fill has more than 
four edges, the Patch command 
works better than the 
NetworkSrf command. 

 
Patch 
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To make a rectangular shape with a curved top and soft corners: 

There are several ways to approach making a soft top like the illustration below. Often, the curves 
you start with are made up of a series of arcs. 

In this exercise we explore two different methods to make the surfaces using the same underlying 
curves. 

  
1 Open the model Soft Corners.3dm. 

  
2 Change to the 02 Separate Curves layer and turn the Original layer off. 

 Notice that the curves are separate arcs that meet at the ends, but are not joined. In this case the 
arcs have tangent continuity.  
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3 Use the Join command (Edit menu: Join) to join the arcs that form the base rectangular shape. 

  
4 Change to the 03 Sweeps layer. 

5 Use the Sweep1 command (Surface menu: Sweep 1 Rail) to make the first surface. 

  
6 Use the Sweep1 command (Surface menu: Sweep 1 Rail) to make the second surface. 

7 At the Select Rail prompt, pick the top edge of the surface you just created, then select the 
cross-sections in order, and press Enter. 

  

 
Sweep along 1 Rail 
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8 In the Sweep 1 Rail Options dialog box, change the Style to Align with surface, then click OK. 

 This will insure tangent continuity with the first surface. 

 
9 Use the Patch command (Surface menu: Patch) to fill in the opening at the center. 

  

 

 

To make a rectangular shape with a curved top and soft corners (Part 2): 

 In this exercise you will start by making new curves. 

1 Change to the 02 Separate Curves layer and turn the 03 Sweeps layer off. 

2 Use the Extend command with the Arc option (Curve menu: Extend Curve > By Arc) to extend 
each of the curves as shown below. 

3 At the Center of arc extension prompt, snap to the center of the same arc. 

 
Patch 
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4 At the End of extension prompt, pick a point. 

 It is important to extend both ends of each arc. 

  

 

 

5 Move the curves from their intersection with the other curve to the end of the base curve as 
shown below. 
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6 Change to the 04 Surfaces layer. 

7 Use the Sweep1 command (Surface menu: Sweep 1 Rail) to make the five surfaces. 

 The surfaces will intersect each other. 

  
8 Use the Trim command (Edit menu: Trim) to trim the ends of the surfaces. 

  
9 Use the Join command (Edit menu: Join) to join the surfaces. 

10 Use the FilletEdge command (Solid menu: Fillet Edge) to fillet the four vertical edges with a 
15mm radius. 

 

 
Sweep along 1 Rail 
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11 Use the FilletEdge command (Solid menu: Fillet Edge) to fillet the top edges with a 10mm 
radius. 

 
12 Use the CutPlane command (Surface menu: Plane > Cutting Plane) to make a cutting plane at 

the origin in the z-axis. 

13 Use the cutting plane to trim the bottom of the polysurface. 

  
 The resulting surface is very clean and smooth with no hard edges. 
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6  Advanced Surfacing Techniques 
 

In this chapter you will learn to make soft domed button shapes, creased surfaces, and how to use 
curve fairing techniques. 

Dome-shaped buttons 
To model a product like a cell phone case, we need soft domed buttons: the button edges have to 
conform to a compound-curved button face. In the following exercise we will discuss several methods 
to make dome-shaped buttons. 

 

Exercise 12—Soft Domed Buttons 
1 Open the model Button Domes.3dm. 

 The key to this exercise is defining a custom construction plane that represents the closest plane 
through the area of the surface that you want to match. Once you get the construction plane 
established, there is a variety of approaches available for building the surface.  

 There are several ways to define a construction plane. In this exercise we will discus three 
methods: construction plane through three points, construction plane perpendicular to a curve, 
and fit a plane. 
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2 Use OneLayerOn to turn on the Surfaces to Match layer to see the surface that determines the 
cut of the button. 

To create a custom construction plane using three points method: 

1 Start the CPlane command with the 3Point option (View menu: Set CPlane > 3 Points). 

2 In the Perspective viewport, using the Near object snap, pick three points on the edge of the 
trimmed hole. 

 The construction plane now goes through the three points. 

 
3 Rotate the Perspective viewport to see the grid aligned with the surface. 

   

To create a custom construction plane perpendicular to a curve: 

 With a line normal to a surface and a construction plane perpendicular to that normal line, you can 
define a tangent construction plane at any given point on the surface. 

1 Start the CPlane command with the Previous option (View menu: Set CPlane > Previous). 

2 Use the Line command with the Normal option (Curve menu: Line > Normal to Surface) to draw 
a line normal to the surface at a point near the edge of the trimmed hole. 

3 Start the CPlane command with the Curve option (View menu: Set CPlane > Perpendicular to 
Curve) 

4 At the Select curve to orient CPlane to prompt, pick the normal.  

 
Set CPlane: 3 Points 

 
Set CPlane: Previous 

 
Surface Normal 

 
Set CPlane: Perpendicular to Curve 
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5 At the CPlane origin prompt, use the End object snap and pick the end of the normal where it 
intersects the surface. 

 The construction plane is set perpendicular to the normal line. 

 

 

 

To create a construction plane fit through points: 

 Using the PlaneThroughPt command to create a surface through a sample of extracted point 
objects will generate a plane that best fits the points.  The CPlane command with the Object 
option places a construction plane with its origin on the center of the plane. This is a good choice 
in the case of the button in this file. There are several curves from which the points can be 
extracted the edge of the button itself, or from the trimmed hole in the surrounding surface. 

1 Start the CPlane command with the Previous option (View menu: Set CPlane > Previous). 

2 Turn on the Surfaces layer. 

3 Use the DupEdge command (Curve menu: Curve From Objects  > Duplicate Edge)  to duplicate 
the top edge of the button. 

  

 
Duplicate Edge 
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4 Copy the duplicated curve vertically twice.  

 The vertical position of these curves will determine the shape of the curved edge of the button. 

  
5 Use the ExtractPt command (Curve menu: Curve From Objects  > Extract Points) on the top 

curve. 

  
6 Use the PlaneThroughPt command (Surface menu: Plane > Through Points) with the extracted 

points that are already selected, then hide the points. 

 A plane is fitted through the points. 

  

 
Extract Points 
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7 Use the CPlane command with the Object option (View menu: Set CPlane > To Object) to align 
the construction plane with the plane. 

  
8 From the View menu, click Named CPlanes, then click Save to save and name the custom 

construction plane. 

9 In the Name of CPlane dialog box, type Button Top and click OK. 

 

 

To loft the button: 

1 Use Loft to make the button.  

2 At the Select curves to loft prompt, select the curves. 

3 At the Select curves to loft ( Point ) prompt, type P and press Enter. 

4 At the End of lofted surface prompt, type 0 (zero) and press Enter. 

 The loft will end at a point in the middle of the plane, which is the origin of the construction plane. 

 
Set CPlane: To Object 

 
Save CPlane 
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5 At the Matching seams and directions... prompt, press Enter. 

  
6 In the Loft Options dialog box, under Style, choose Loose. 

 With the Loose option, the control points of the input curves become the control points of the 
resulting surface, as opposed to the Normal option, in which the lofted surface is interpolated 
through the curves. 

 
7 Turn on control points on the lofted surface. 

8 Select the next ring of points out from the center. 

 Select one point and use SelV or SelU to select the whole ring of points. 

  

9 Use the SetPt command (Transform menu: Set Points) to set the points to the same Z-elevation 
as the point in the center. 

 Remember, this elevation is relative to the current construction plane. 

10 In the Set Points dialog box, check the Z box only and Align to CPlane option. 

 
Set Points 
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11 At the Location of points prompt, type in 0 and press Enter. 

 
 Aligning the row of points with the central point makes a smooth top on the button. 

  
12 In the Perspective viewport, use the SetView CPlane Top command (View menu: Set 

Camera > CPlane Top) to set the construction plane back to the default position. 

 Once the surface is made you can adjust it by selecting rings of points with elevator mode, or in 
another orthogonal view, move the points up and down to alter the shape. Remember to move the 
middle point and the next ring of points together so they do not go out of plane with one another. 

  

To use a patch surface to make the button: 

1 Use the DupEdge command to duplicate the top edge of the surface. 

2 Move the duplicated curve in the Z-direction a small amount. 

 
Set CPlane: World Top 
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3 Use the ExtractPt command on the curve. 

4 Use the PlaneThroughPt command with the extracted points that are already selected, then hide 
the points. 

5 Use the CPlane command with the Object option to set the construction plane to the planar 
surface. 

  
6 Make a circle or ellipse centered on the origin of the custom construction plane. 

   
7 Use the Patch command, selecting the top edge of the button and the ellipse or circle. 

  

 
Patch 
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8 In the Patch options dialog box, set the point sampling small enough to get a good join at the 
edge, and uncheck the adjust tangency setting. 

 The size and vertical position of the circle/ellipse will affect the shape of the surface. 

  
9 Join the surfaces and use the FilletEdge command to soften the edge. 

10 Undo back to before the Patch, move the ellipse down, and repeat the command. 

11 In the Patch options dialog box, check the adjust tangency setting. 

 The surface is tangent to the edge and concave on the top. 

  

To use a rail revolve surface to make the button: 

1 Use the DupEdge command to duplicate the top edge of the surface. 

2 Move the duplicated curve in the Z-direction a small amount. 

3 Use the ExtractPt command on the curve. 

4 Use the PlaneThroughPt command with the extracted points that are already selected, then hide 
the points. 

5 Use CPlane command with the Object option to set the construction plane to the planar surface.  
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6 Use the Line command with the Normal option (Curve menu: Line > Normal to Surface) to draw 
a line normal to the surface down from the center of the plane to use as an axis. 

  
7 Use the Extend command (Curve menu: Extend Curve > By Line) to extend the edge at the seam 

through the rectangular surface. 

  
8 Use the Intersect command (Curve menu: Curve From Objects  > Intersection) to find the 

intersection between the extended line and the rectangular surface. 

  
9 Use the Curve command to draw a curve from the end of the normal line, using the intersection 

point as the middle control point, to the end of the seam to use as a profile curve. 
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10 Start the RailRevolve command (Surface menu: Rail Revolve). 

11 At the Select profile curve ( ScaleHeight ) prompt, type S and press Enter. 

12 Select the profile curve (1), the top edge of the surface (2) as the path curve, and the ends of the 
normal (3 and 4) as the axis for the revolve. 

  
13 Use the MatchSrf command to match the two surfaces to tangent continuity. 

  
 Another option would be to not bother to make the profile curve tangent. With this method you 

would fillet the edge to soften it. 

  

 
Rail Revolve 

 
Match Surface 
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Creased surfaces 
Often a surface needs to be built with a crease in it which begins with an angle and diminishes to zero 
angle at the other end. The following exercise covers two possible situations. 

 

Exercise 13—Surfaces with a crease 
 The key to following exercise is to get two surfaces that match with different continuity at each 

end. At one end we will match the surface with a 10 degree angle and at the other end we will 
match the surface with curvature continuity. To accomplish this we will create a dummy surface at 
the correct angles and use this to match the lower edge of the upper surface. 

1 Open the model Crease 01.3dm. 

2 Turn on the Curve and Loft layers.  

3 Make the Loft layer current. 

4 Use the Loft command to make a surface from the three curves on the Loft layer.  

  
 We are going to make a surface that includes all the curves but has a crease along the middle 

curve. 

 
Loft 
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5 Use the middle curve to Split the resulting surface into two pieces. 

  
6 Use the ShrinkTrimmedSrf command (Surface menu: Surface Edit Tools > Shrink Trimmed 

Surface) on both surfaces.  

 The surfaces are now untrimmed. 

 
7 Hide the lower surface. 

To create the dummy surface: 

 We will change the top surface by matching it to a dummy surface that we will create. The dummy 
surface will be made from one or more line segments along the bottom edge of the top surface 
that are set at varying angles to it. To get a line that is not tangent but at a given angle from 
tangent, two line segments are needed. They are touching at their ends but are at an angle from 
each other. 

1 Change to the Dummy Curve layer. 

2 In the Top viewport, use the Polyline command to make the first segment 20 units long and 
parallel to the x-axis. 

  

 
Shrink Trimmed Surface 
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3 Make the next segment 20 units long and at a 10 degree angle from the x axis.  

 The crease will have a maximum angle of 10 degrees. 

4 Start the OrientCrvToEdge command (Transform menu: Orient > Curve To Edge). 

5 At the Select curve to orient prompt, in the Front viewport, select the left end of the polyline.  

 The orientation of the curve is relative to the construction plane where the curve is picked. 

 The command uses the active construction plane's z-direction as the reference for determining the 
alignment of the curve to the surface normal at the target edge. The end closest to the end picked 
will be the end touching the edge. 

6 At the Select target surface edge prompt, select the bottom edge of the surface. 

7 At the Pick target edge point prompt, snap to the endpoint. 

  
8 At the Pick target edge point prompt, snap to the other endpoint. 

9 At the Pick target edge point prompt, press Enter. 

 The result should look like the image above. If the result looks different (the curve angles the 
wrong way), flip the surface normals on the target surface and place the polylines again. 

 The upper segment of polyline is tangent to the surface, and the lower segment is at 10 degrees 
from tangent. 

10 Explode the polylines. 

11 Move the 10-degree segment of the polyline at the right side of the surface by its upper end to 
coincide with the upper end of the tangent segment. 

  

 
Orient Curve to Edge 



 

Notes: 

Robert McNeel & Associates ❑  95 

12 Delete the tangent segment on the left. 

13 Delete the 10-degree segment of the polyline at the right side of the surface. 

 
14 Make the Dummy Surface layer current. 

15 Use the Sweep1 command (Surface menu: Sweep 1 Rail) to create the dummy surface.  

16 Select the lower edge of the upper surface as the rail and the two line segments as cross-section 
curves.  

 Make sure to use the surface edge and not the original input curve as the rail for the sweep. 

  
17 In the Sweep 1 Rail Options dialog box, under Style, choose Align with surface. 

 This option causes the cross-section curves to maintain their orientation relative to the surface 
edge. A tangent curve (2) will be swept along the edge holding tangency all along unless another 
shape curve (3) with a different orientation is encountered, in which case there will be a smooth 
transition from one to the next. 

 

 

 
Sweep 1 Rail 
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To match the surface to the dummy surface: 

1 Use the MatchSrf command to match the upper surface to the dummy surface. 

2 At the Select surface to change - select near edge prompt, select the lower edge of the upper 
surface.  

  
3 At the Select target surface - select near edge prompt, select the upper edge of the dummy 

surface. 

4 In the Match Surface dialog box, choose Tangency and check Match edges by closest point. 

 This will keep distortion to a minimum.  

 
5 Show the lower (red) surface and hide the (blue) dummy surface. 
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6 Join the lower surface with the upper surface. 

 The crease fades smoothly from one end to the other of the polysurface. If more control is needed 
over the angles of the crease, more segments can be placed to create the dummy surface. 

 
 Because the surfaces are untrimmed, you have the option to merge the surfaces back into one 

surface. 

Exercise 14—Surfaces with a crease (Part 2) 
 In this exercise there is no convenient relationship between the crease curve and the surface. 

While similar to the other example, the upper surface is made with a two rail sweep.  

To create a crease with trimmed surfaces: 

1 Open the model Crease 02.3dm. 

2 Use the ShrinkTrimmedSrf command (Surface menu: Surface Edit Tools > Shrink Trimmed 
Surface) on the surface.  

 
3 Use the RebuildEdges command (Analyze menu: Edge Tools > Rebuild Edges) to rebuild the 

edges of the surface to a 0.001 tolerance. 
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4 Use the Line command (Curve menu: Line > Single Line) to draw a single line anywhere in the 
viewport.  

 We will use this line to make a dummy surface. 

  
4 Use the OrientCrvToEdge command (Transform menu: Orient > Curve to Edge) to move the 

curve for the dummy surface to the upper edge of the lower surface. 

5 Place a line at each end of the edge and somewhere in the middle of the edge. 

   
 If the line flips over at either end, place it as close to the end as you can and move it later. 

 The line is tangent to the surface. 
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6 Move each line segment by moving its upper end to the lower end of the same segment. 

  

To use a custom construction plane to rotate a curve: 

1 Use the CPlane command (View menu: Set CPlane > Perpendicular to Curve) to set the 
construction plane to align with the line at the left of the surface. 

 
2 Use the Rotate command (Transform menu: Rotate) to rotate the line -15 degrees 

(counterclockwise). 

  
3 Repeat these steps for the line in the middle of the surface. 
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To make the dummy surface: 

1 Use the Sweep1 command to create the dummy surface.  

2 Select the upper edge of the lower surface as the rail and the three line segments as cross-section 
curves. Use the Align with surface style for the sweep. 

 
3 Use the Sweep2 command to make the upper surface.  

 Choose the upper edge of the dummy surface as a rail and the long curve at the top as the other 
rail. Choose the curves at both ends as the cross-section curves.  

  
4 In the Sweep 2 Rails Options dialog box, for the Rail continuity of edge A, choose Tangency. 

5 Hide the dummy surface. 

6 Join the lower surface with the upper surface. 
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Curve fairing to control surface shapes 
Fairing is a technique to simplify curves while improving their curvature graphs and keeping their 
shape within tolerance. It is especially important to fair curves that are generated from digitized data, 
intersections, extracted isocurves, or curves from two views. 

Generally curves that are single-span curves work better for this process. A single span curve is a 
curve that has one more control point than the degree. Examples are a degree 3 curve with 4 control 
points, a degree 5 curve with 6 control points, or a degree 7 curve with 8 control points. 

To make a surface with fair curves: 

1 Open the model Fair Curves.3dm. 

  
2 Select the curves and use the Loft command (Surface menu: Loft) to make a surface. 

 The surface is very complex. It has too many isocurves for the shape, because the control point 
structures of the curves are very different. 

  
3 Undo the loft. 

4 Change to the Tangency Direction layer and turn on the control points on the original curves. 

 
Loft 
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5 To maintain the tangency direction of the originals, make a line tangent to the originals from the 
end points and coming back towards the curve, any length. Use the Tab lock and snap to the 
second point to extend the line. 

 

 
6 Change to Rebuilt Curves layer, and Lock the Tangency Direction layer 

7 Use the Rebuild command (Edit menu: Rebuild) to rebuild the curves. 

Note: Although there is a Rebuild option in the Loft command, rebuilding the curves before lofting 
them gives you control over the degree of the curves as well as the number of control points.  

8 In the Rebuild Curve dialog box, change the Degree to 5 and the Point Count to 6 points. 
Uncheck Delete input, check Current layer. 

  
 Click the Preview button. Notice how much the curves deviate from the originals. 

 
Rebuild 
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Note: This makes the curves into single-span curves. Single-span curves are Bézier curves. A single-
span curve is a curve that has degree +1 control points. While this is not necessary to get high 
quality surfaces, it produces predictable results. 

9 Lock the Original Curves layer. 

10 Select one curve, turn on the points and the curvature graph. 

11 Fair the curve by adjusting points until it matches the original curve closely enough.  

 Start by moving the second point of the rebuilt curve onto the tangent line. Use the Near object 
snap to drag along the tangent line. 

 

 
12 Check the curvature graph to make sure the curve has smooth transitions. 

 The curves are fair when the points are adjusted so the rebuilt curves match the original locked 
curves closely, with good graphs. 

13 Fair the other curves the same way. 
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14 Loft the new curves.  

 Note the shape and quality of the surface. It has very few isocurves but it has close to the same 
shape as the first surface. 
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7  Use Background Bitmaps 
 

This exercise describes the steps in creating a case for a handset, using bitmaps as templates. In this 
exercise we will focus on making curves from bitmaps images and using fairing techniques on the 
curves before making the surfaces. 

We will begin by taking scanned sketches and placing them in three different viewports. The three 
hand-drawn images need to be placed in their respective viewports and scaled appropriately so that 
they match each other.  

You can align images more easily if they have been aligned and cropped so that they share the same 
length in pixels. It helps to darken and slightly reduce the contrast of images that have a lot of bright 
white in them. This allows a greater range of colors to be seen against them when tracing them in 
Rhino. 

Exercise 15—Handset 
1 Open the model Handset.3dm. 

2 From the Tools menu, click Toolbar Layout. 

3 In the Toolbars dialog box, check Background Bitmap to open the toolbar, then close the dialog 
box. 

 Use the toolbar buttons for the next part of the exercise. 
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To place background bitmaps: 

We will begin by making reference geometry to help in placing the bitmaps. 

1 Make a horizontal line, from both sides of the origin of the Top viewport, 150 mm long. 

  
2 Toggle the grid off in the viewports that you are using to place the bitmaps by pressing the 

F7 key. 

 This will make it much easier to see the bitmap. The grid is displayed in the illustrations for 
reference only. 

3 In the Front viewport, use the BackgroundBitmap Place command (View menu: Background 
Bitmap > Place) to place the HandsetElevation.bmp.  

  
4 Use the BackgroundBitmap Align command (View menu: Background Bitmap > Align) to align 

the ends of the handset to the line. 

  

 
Place Background Bitmap 

 
Align Background Bitmap 
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5 Change the Right viewport to a Bottom view. 

6 Use the same technique to place and align the HandsetTop.bmp and HandsetBottom.bmp in 
the respective viewports. 

  

To build the case: 

1 In the Front and Bottom viewports, trace the curves you need to define the form of the case. 
Since the bottom view of the object is symmetrical you can make one curve.  

  

 The front view curves describing the top and bottom edges of the case should extend on the right 
past the form in the background image approximately the same amount as the corresponding top 
view curves do. You can draw them too long and trim both top view and both front view edge 
curves off with a single cutting plane. Now draw the curve in the Front viewport that defines the 
parting line separating the top and bottom halves of the case. This curve is the front view of the 
plan view’s edge curves. It should be extended to the right the same distance as the other edge 
curves. 

2 In the Bottom viewport, select the parting line curve and the outline curve. 
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3 Use the Crv2View command (Curve menu: From Two Views) to create a curve based on the 
selected curves. 

 A 3-D curve is created.  

  
4 Hide or Lock the two original curves. 

 Now there are three curves. 

  
5 Turn on the control points for the curves. 

 Note the number of control points and the spacing. This is an example of curves that need to be 
faired before you can create a good surface from them. 

  



 

Notes: 

Robert McNeel & Associates ❑  109 

6 Fair the curves, using the same technique as in the previous exercise. 

  
7 Mirror the 3-D curve for the other side. 

 The macros ! Mirror 0 1,0,0 and ! Mirror 0 0,1,0 are very useful for accomplishing this quickly if 
they are assigned to a command alias and if the geometry is symmetrical about the x or y axis.  

  
8 Loft the faired curves. 

 Note the quality of the surface and how few isocurves there are. 
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8  An Approach to Modeling 
 

A common question that occurs when modeling, is “Where do I start?” In this section we will discuss 
various approaches to the modeling process. 

There are two things to consider before your begin modeling: if reflections, fluid flow, air flow, or the 
ability to edit using control points are important in the finished model, you will want to begin your 
models with geometry that consists of cubic (degree 3) or quintic (degree 5) curves. If these are not 
important, you can use a combination of linear (degree 1), quadratic (degree 2), cubic or quintic 
curves. 

Start with simple shapes, the details can be added later. Begin by creating layers for the different 
parts. This will help separate the parts for visualization, and help with matching the parts as you go.  

We will review different products to try to determine which kind of surfaces are most important and 
some approaches to modeling the product. 

Exercise 16—Cutout  
 This exercise shows an approach to making a cutout surface which blends smoothly and 

seamlessly into an existing curved surface. The new surface has an arbitrary relationship to the 
existing surface so the general strategy can be used in other cases. 

  
1 Open the model Scoop.3dm. 
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2 Make the Cut-out Curves layer current, turn on the Original Surface layer, turn off the 
Completed Scoop layer. 

  
3 In the Top viewport, select the curves. 

4 Start the Project command (Curve menu: From Objects > Project). 

5 At the Select surfaces or polysurfaces to project onto prompt, select the surface. 

 The curves will be copied to the surface. 

  

6 Start the ExtendCrvOnSrf command (Curve menu: Extend > Curve On Surface). 

7 At the Select curve to extend prompt, select the outer curve on the surface.  

8 At the Select surface that curve is on prompt, select the surface. 
 The ends of the curve are extended to the edge of the surface. 

  

 
Project 

 
Extend Curve On Surface 
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9 Use the Trim command (Edit menu: Trim) to trim the curves with each other. 

  
10 Join the three small curves into one. 

11 Duplicate the surface and hide the duplicate. 

12 Use the joined curve to trim away the part of the surface which is outside the curve. 
 This leaves a small trapezoidal surface. This surface is a dummy used to match a new surface to 

and will be deleted later.  

  

13 Use the ShrinkTrimmedSrf command (Surface menu: Edit Tools > Shrink Trimmed Surface) to 
make this surface easier to use. 
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To make the bottom of the cutout: 

 Next we will make a surface for the bottom of the cutout. The cutout is round at one end, but we 
will build a rectangular surface and trim it to be round at one end. This approach allows for a much 
lighter, more easily controlled surface. 

1 Make one curve first with as few points as possible.  

 Look at from various views while you work. Five or six points should be enough in the curve.  

 Use the curvature graph to get a nice fair curve. 

  
2 Copy the curve to the other edge.  

3 Adjust the curves by moving the control points until they look the way you want.  

 The curves should be as wide as the dummy surface. Make sure the curves extend past the end of 
the cutout curve in the Top viewport. 

  
4 Use the Match command (Curve menu: Edit Tools > Match) to match the curves with curvature 

continuity to the edges of the dummy surface.  

 If matching makes the curve distort too much add a knot and try again. EndBulge and further 
point editing may be needed. 

5 Use the Loft command (Surface menu: Loft) to create the surface between the two curves. 
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6 Use the MatchSrf command (Surface menu: Edit Tools > Match) to match the lofted surface  to 
the edge of the dummy surface.  

  
 If the lofted surface distorts too much, undo and restart the MatchSrf command.  

7 In the Match Surface dialog box, click Options.  

8 In the Match Surface Options dialog box, click Preserve isocurve direction.  

 This time the match should not distort the surface.  

9 Use the ChangeLayer command to move the dummy surface to the Dummy Surface layer.  

To make the sides of the cutout: 

 To make the sides of the cutout, we will extrude the projected outline with 10 degrees of draft and 
trim it with the lofted surface. 

1 Select the projected curve. 

2 Use the Rebuild command (Curve menu: Edit Tools > Rebuild) to rebuild the curve with as few 
points as you can, while still maintaining the curvature of the original curve. 

  
3 Use the Extrude command (Surface menu: Extrude > Straight) to extrude the rebuilt curve.  

4 At the Extrusion distance ( Direction  BothSides  Tapered ) prompt, type T and press Enter. 

5 At the Draft angle <0 > prompt, type –10 and press Enter. 

 
Rebuild 

 
Extrude 
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6 At the Extrusion distance ( Direction  Corner=round ) prompt, pull the surface until it fully 
intersects with the bottom surface and pick.  

 The extruded surface is a very dense surface. 

  
7 Use the Rebuild command (Surface menu: Edit Tools > Rebuild) to rebuild the surface. 

 Fifty to seventy points in the V-direction and 4 points in the U-direction should be enough. 

  
8 Trim the lofted surface with the extrusion to create the floor of the cutout.  

9 Use the Split command (Edit menu: Split) with the Isocurve option to split the ends of the 
extruded surface at the intersection with the original projected curve on both sides. 

  

 
Rebuild Surface 
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10 Delete the ends that are split. 

  
11 Trim the sides of the extruded surface with the floor of the cutout. 

  

To create the fillets: 

 Now the surfaces are ready to be filleted.  

1 Show the main surface. 

2 Use the FilletSrf command (Surface menu: Fillet Surface) to make the fillets between the bottom 
surface and the sides. 

3 At the Select first surface to fillet ( Radius=1 Extend=Yes Trim=Yes ) prompt, type 5 and press 
Enter. 

4 At the Select first surface to fillet ( Radius=5 Extend=Yes Trim=Yes ) prompt, click Extend to 
change the setting to No. 

5 At the Select first surface to fillet ( Radius=5 Extend=No Trim=Yes ) click Trim. 

6 At the Trim <Yes > ( Yes No Split ) prompt, click No. 

7 At Select first surface to fillet ( Radius=5 Extend=No Trim=No ) prompt, pick the bottom 
surface.  

8 At the Select second surface to fillet ( Radius=5 Extend=No Trim=No ) prompt, pick the side 
surface near the same spot. 

 
Fillet Surface 



 

Notes: 

Robert McNeel & Associates ❑  118 

9 Repeat this for the side surface and the original surface. 

 The two fillets cross each other. We will trim them both back to their intersection points. 

   
10 Use the DupEdge command (Curve menu: From Objects > Duplicate Edge) to duplicate the upper 

edge of the lower fillet and the lower edge of the upper fillet. 

11 Use the Intersect command (Curve menu: From Objects > Intersection) to find the intersections 
between the duplicated curves for the fillet edges on the side surfaces. 

  
12 Select the duplicated curves and the intersection points. 

13 Use the Invert command (Edit menu: Select Objects > Invert) to invert the selection. 

14 Use the Hide command (Edit menu: Visibility > Hide) to hide the selected geometry.  

 
Duplicate Edge 

 
Hide: Invert 
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15 Use the Circle command with AroundCurve option (Curve menu: Circle > Center, Radius) to 
create a curve at the point, use the OnCrv object snap to select one of the curves. 

  

 

 

16 Use the PlanarSrf command (Surface menu: From Planar Curves) to create a circular surface at 
the intersection point. 

  
17 Repeat these steps for the other intersection. 

  

 
Circle: Around Curve 
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18 Trim the fillets to the surfaces.  

19 Trim the sides to the fillets.  

  
20 In the Top viewport, use the Extend command with the Type=Smooth option to extend the 

bottom ends of the fillet curve to the ends of the cutout surface. 

  
21 Use the Project command to project the extended curve onto the original surface. 

   
22 Use the extended curve to trim the bottom surface. 
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23 Repeat steps 19 and 20 for the curves at the top of the upper fillet. 

24 Duplicate the edge of the dummy surface and trim the curves to make a closed loop. 

  
25 Use the projected curve and the edge of the dummy surface to trim the cutout from the original 

surface. 

  
 

26 Use the SplitEdge command (Analyze menu: Edge Tools > Split Edge) to separate the short 
edges on the original surface into three separate parts. 

  
27 Duplicate the edge curves at the trimmed edges of the fillets and join them. 

  

 
Split Edge 

 
Merge Edge 
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28 Use the Sweep2 command with Rail continuity=Tangency or the NetworkSrf command to 
create the last two surfaces.  

 The surfaces start with the s-shaped curves that you duplicated and end with a flat line at the split 
edge. 

  
29 Join the cutout surfaces and then trim a hole at the bottom. 

30 Mirror and Trim to get the other scoop. 

  
 



 

Notes: 

Robert McNeel & Associates ❑  123 

9  Use 2-D Drawings 

Use 2-D drawings as part of a model 
Often you are asked to take an existing design from a 2-D graphics package and include it as part of a 
Rhino model. One of the tasks to complete will include moving and positioning the graphic onto the 
model. 

In the following exercise we will use a logo design created in Adobe Illustrator to make a 3-D logo on 
a model. 

Exercise 17—Importing an Adobe Illustrator file 
 In this exercise we will make a custom construction plane, import an Illustrator file, and place a 

logo on some surfaces. 

1 Open the model Air Cleaner.3dm. 

  

To import a file: 

1 Start the Import command (File menu: Import). 

2 Change the Files of type to Adobe Illustrator (*.ai), and choose the AirOne_Logo.ai to import. 
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3 In the AI Import Options dialog box, click OK. 

 The logo is selected and located on the Top construction plane. 

 
 

4 Start the Layer command. 

5 Make a new layer named Logo1 and turn off the new layer. 

6 Right click on the Logo1 layer, then click Copy Objects to Layer to make a copy of the logo on 
the new layer. 

To create the custom construction plane: 

1 Select the flat disc shaped surface. 

 It is important to know normal direction and the U- and V-directions of the surface. 

2 Start the Dir command (Analyze menu: Direction). 

  
3 At the Press Enter when done ( UReverse VReverse SwapUV Flip ) prompt, click on the surface 

to flip the normal direction. 

 Put your cursor over the surface and observe the red and green direction arrows. 

4 At the Press Enter when done ( UReverse VReverse SwapUV Flip ) prompt, click UReverse or 
VReverse to change the direction of U and V (surface "x" and "y" directions).  

5 At the Press Enter when done ( UReverse VReverse SwapUV Flip ) prompt, press Enter.  

 The direction of U, V, and the normal have been changed. 

 
Direction 
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6 Use the CPlaneToObject command (View menu: Set CPlane > To Object) to realign the 

Perspective viewport construction plane to the surface. 

  

To move the logo to the custom construction plane: 

 The command we will use to move the logo to the flat disk shaped surface uses the position of the 
object relative to a construction plane. Make sure Top is the active viewport and the logo is 
selected. 

1 Start the RemapCPlane command (Transform menu: Orient > Remap To CPlane). 

2 At the Click on CPlane to map to ( Copy ) prompt, click in the Perspective viewport. 

 The logo is positioned in the same relative position on the custom construction plane. 

  

 
Remap To CPlane 
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3 Rotate or move the logo to a new position. 

  
4 Use the Extrude command (Solid menu: Extrude Planar Curve) with the BothSides option to 

make the text 3-D. The extrusion distance should be 2 mm. 

  
5 Use the BooleanDifference command (Solid menu: > Difference) to recess the text into the 

surface. 

  

To place the logo on an irregularly shaped surface: 

 In this part of the exercise, we will import another logo and position it on the cutout surface. 

1 Select the purple cutout surface. 

2 Use the Invert command (Edit menu: Select > Invert) to invert the selection set. 

3 Use the Hide command (Edit menu: Visibility > Hide) to hide everything but the cutout surface. 

 
Invert Hide 
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4 Use the ExtractIsocurve command (Curve menu: From Object > Extract Isocurve) to extract a 
lengthwise isocurve on the cutout surface. 

 We will use this curve to align the logo. 

  
5 Use the Length command (Analyze menu: Length) to check the length of the extracted isocurve. 

6 Turn on the Logo1 layer. 

  
7 In the Perspective viewport, Rotate the logo 180 degrees about the 0,0 point. 

  

 
Extract Isocurve 
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8 Use the Line command with the BothSides option to draw a line from 0,0 that is the same length 
as the extracted isocurve. 

 The line should be oriented so that it goes through the center of the logo. 

  
9 Window select the logo, not the line. 

10 Start the Flow command (Transform menu: Flow along Curve). 

11 At the Original backbone curve - select near end ( Line Copy ) prompt, select the line. 

12 At the New backbone curve - select near end ( Line Copy ) select the extracted isocurve. 

 The logo follows the curve. 

  

To raise the logo lettering 

1 In the Perspective or Top viewport, use the Split command (Edit menu: Split) to split the 
surface with the logo curves. 

  

 
Flow along Curve 
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2 Select the logo surfaces. 

 Do not pick the parts of the surfaces that are inside the letters (A, O, and N). 

3 Start the OffsetSrf command (Surface menu: Offset Surface). 

4 At the Offset distance <1 > ( Flip Solid Loose Tolerance ) prompt, move your cursor over the 
logo surface. If the normal is pointing down, click on the surface to flip it. 

5 At the Offset distance <1 > ( Flip Solid Loose Tolerance ) prompt, click Solid to activate the 
solid option. 

6 At the Offset distance <1 > ( Flip Loose Tolerance ) prompt, type 1 and press Enter. 

 The logo is offset with the sides filled in. 

  
7 Use the ExtractSrf command (Solid menu: Extract Surface)  to separate the bottom surfaces 

from the logo and delete them. 

8 Use the Join command (Edit menu: Join) to join the logo with the cutout surface. 

9 Use the FilletEdge command (Solid menu: Fillet Edge) with a .01 radius to soften the top edges 
of the logo. 

 

 
Offset Surface 
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Make a model from a 2-D drawing 
One of the more difficult modeling tasks in modeling is to interpret a set of 2-D views into a 3-D 
model. Very often the drawings are precise in some areas and inexact in areas where complex surface 
transitions must take place in three dimensions.  

It is best to consult directly with the designer to clarify difficult areas, but this is not always possible. 
Usually there are discrepancies between the views. 

If there is no physical model available as reference, some decisions must be made along the way 
about the best way to interpret the sketch or drawing. For example, you will have to consider which 
view to consider the most accurate for a given feature.  

In the following exercise we will explore some strategies to create a blow-molded plastic bottle from a 
set of 2-D drawings. In this exercise we have a control drawing showing three views of the bottle. It is 
roughly dimensioned, but we need to hold to the designer’s curves wherever possible. 

We will only have time to finish the first stage of this model in class. We will complete the bottle 
surfaces, but the details will be left out. Included in the models folder is a finished bottle for your 
review. 

Exercise 18—Making a detergent bottle 
1 Open the model Detergent Bottle.3dm. 

  
2 In the Top viewport, window select the objects that make the top view (lower left) including the 

dimensions of the 2-D drawing. 

3 Use the Group command to group the selected objects (Edit menu: Group). 

4 Repeat the previous steps to group the objects for the front view (upper left) and the right view 
(upper right). 

 Each of the views is a separate group of objects. 
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To orient the views: 

1 Select the top view group. 

2 Use the ChangeLayer command (Edit menu: Layers > Change Object Layer) to change the layer 
to the 3D Template Top layer. 

3 In the Top viewport, use the Move command to move the center of the circles to 0,0. 

  
4 Select the front view group. 

5 Use the ChangeLayer command to change the layer to the 3D Template Front layer. 

6 In the Top viewport, use the Move command to move the intersection of the centerline and the 
horizontal line at the bottom to 0,0. 

7 Start the RemapCPlane command (Transform menu: Orient > Remap to CPlane). 

8 At the Click on CPlane to map to ( Copy ) prompt, click in the Front viewport. 

 The view is oriented in 3-D space. 

  
9 In the Top or Perspective viewport, select the right view group. 

10 Use the ChangeLayer command to change the layer to the 3D Template Right layer. 

11 In the Top viewport, use the Move command to move the intersection of the centerline and the 
horizontal line at the bottom to 0,0. 

12 From the Transform menu: Orient, then click Remap to CPlane. 
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13 At the Click on CPlane to map to ( Copy ) prompt, click in the Right viewport. 

 The view is oriented in 3-D space. 

  
 Frequently 2-D curves for design control drawings will not be as carefully constructed as would 

you like for making accurate geometry. Before building 3-D geometry from the 2-D curves, check 
the curves and correct any errors that can be found.  

To create the 3-D curves for the front view: 

1 Change to the 3d Curves layer, turn off all layers except 3d Template Front layer. 

2 Use the Duplicate command (the right-click button you made in a previous exercise) to copy the 
curve on the right. 

3 Use the ChangeLayer command to change the duplicated curve to the 3D Curves layer. 

4 Lock the 3d Template Front layer. 
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5 Use the Mirror command (Transform menu: Mirror) to mirror the curve (1) around the origin. 

 This curve will be used to make a new curve for the left side of the bottle. The left hand profile 
curve in the front view is actually unknown because the walls of the bottle are inset by 2mm. 

  
6 Turn on points for this curve, and adjust it to create the new curve for the left side. 

  
7 Turn on points for the right hand curve and select the bottom points on both curves. 

  
8 Use the SetPt command (Transform menu: Set Points) to set the world z-coordinate of the points 

to 0. 

 This will make a sharp corner at the bottom. The fillet will be added to the surface later. 
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9 Select the two points closest to the bottom on the left hand curve. 

  
10 Use the SetPt command to align the upper point in the X direction to the lower point. 

11 Repeat this step for the right hand curve. 

 This ensures that the curves will be tangent to a vertical at the lower endpoint. 

To create the 3-D curves for the right view: 

1 Turn off the 3d Template Front layer and turn on the 3d Template Right Layer. 

2 Select the curve at the left, front of the bottle. 

3 In the Top viewport, use the Rotate command (Transform menu: Rotate) with the Copy option to 
rotate the curve around the origin, by 90 degrees. 

  
4 Turn on the points for this curve, and adjust it. 

  
5 Use the SetPt command to set the world z-coordinate of the last point to 0. 

6 Select the two points closest to the bottom on the new curve. 

7 Use the SetPt command to align the points in the World Y direction. 
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To create the 3-D curves for the top view: 

1 Turn off the 3d Template Right layer and turn on the 3d Template Top Layer. 

2 Use the Duplicate command to duplicate the boundary curve and the largest circle. 

  
3 Use the ChangeLayer command to change the duplicated curve to the 3D Curves layer. 

4 Lock the 3d Template Top layer. 

5 Use the SetPt command to move the duplicated circle to the same z-elevation as the top of the 
curves. 

  
6 Use the Split command to split the circle at the top into an arc using the curves at the left and 

right as cutting edges. 

  

To make a surface for the bottle with a sweep: 

 From the drawing these are the only curves we have available to define the shape, so we will use 
these curves directly to create the surface. 

1 Change to the Surfaces Sweep2 layer. 
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2 Select the curves and use the Sweep2 command (Surface menu: Sweep 2 Rails) to make a 
surface. 

3 In the Sweep 2 Rails Options dialog box, click OK. 

 The surface has an unacceptable pinch near the top and bulge around the back of the surface. 

   

To make a surface for the bottle from a network of curves: 

1 Undo the previous operation. 

2 Change to the Surfaces NetworkSrf layer. 

3 Select the curves and use the NetworkSrf command (Surface menu: Curve Network) to make the 
surface again. 

 It is better, but it still has a slightly pinched area at the back near the top.  

  
 To eliminate this defect, an additional curve needs to be created. 

4 Undo the previous operation. 

To make the surfaces for the bottle from the edge curves: 

 The area causing the most problems in the earlier attempts was the transition along the back, 
where the handle will be, as it goes from a rounded rectangular shape to an arc at the top. We will 
add an additional curve and make the surface from several surfaces. 

1 Change to the Surfaces EdgeSrf layer. 
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2 Copy the back profile curve and place it using the Knot object snap on the knot just on the flat 
side of the base curve, near the corner.  

  
3 Drag the top point of this curve to the top circle approximately one-third of the way between the 

back profile curve and the side profile curve. 

 This gives a little more control over the surface, especially at the top edge. 

  
4 Split the top circle and the base curve with the vertical curves.  

  
5 Rebuild (Edit menu: Rebuild) the middle base curve to degree 3 with 4 points. 

  

 
Knot 



 

Notes: 

Robert McNeel & Associates ❑  138 

6 Use the Match command (Curve menu: : Curve Edit Tools > Match) to match it to the other 
curves. 

  
7 Use the EdgeSrf command (Surface menu: Edge Curves) to make the 3 surfaces. 

  
8 Use the MatchSrf command (Surface menu: Surface Edit Tools > Match) to match the surfaces at 

their edges for tangency. 

9 In the Match Surface dialog box, check Average Surfaces, Preserve opposite end, and 
Tangency. 
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10 In the Match Surface Options dialog box, experiment with the Isocurve direction 
adjustments and preview until you get the best surface. 

  
11 Use Zebra analysis (Analyze menu: Analyze Surface > Zebra) to evaluate the results. 

  
 When the surfaces are all matched, the top edges are likely to have come off the circle very 

slightly. 

12 To restore these, extrude the top input curves up a short distance and use the MatchSrf 
command to match the top edges of the surfaces to the extrusions using Position only. 

  
13 Select the surfaces and use the Mirror command to copy the surfaces for the other side of the 

bottle. 

14 Use the MatchSrf command to match the edges for tangency. 
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15 Join the surfaces together.  

  
16 Check for naked edges. 

On your own: 

Make the inset surface and the handle. Fillet the edges where indicated in the 2-D drawing. Included 
in the model directory is a finished bottle for your review.  
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10  Sculpting 
 

Designers can build a relatively undefined surface and then use a variety of transform and analysis 
tools to sculpt a surface in 3-D space in an intuitive and direct manner. 

 

Curves can be placed approximately. The curves should be edited copies of a single original if possible. 
This ensures that they will be compatible when lofted, and create the simplest, most easily edited 
surface. 

In the following exercise four curves have been created for you to use. 
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Exercise 19—Dashboard 
1 Open the model Dash.3dm.  

2 Loft the four curves together with the Loose option from the dropdown list. Using Loose creates 
the simplest possible geometry and is essential to creating a surface with this technique.  

 The surface will not touch the interior curves of the loft with this option, but it should be very 
smooth and clean looking. 

  
3 Turn on points.  

 If you also turn on points for the input curves you will see that the point structure of the surface 
exactly matches that of the four curves.  

  
 There is a steering wheel on a locked layer to help you get a sense of scale and positioning of any 

elements you might wish to add. 

4 Turn off the Curve layer. 

5 Turn on the points for the surface, use the SetPt command (Transform menu: Set Points) to align 
the groups of points in the x direction. 
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6 Select the points nearest the top edge of the steering wheel. 

  
7 Start the Weight command (Edit menu: Control Points > Edit Weight). 

8 In the Set Control Point Weight dialog box, move the slider to the right. 

 Changing the weight of some of the points gives you more or less local control over the surface 
nearest the points. 

  
9 Use the Nudge keys to move the points in the Top and the Front viewports. 

 Notice the sharpness of the bulge closest to the points where weight was changed.  

  

 
Edit Control Point Weight 
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 If the surface starts to look chunky, use the Refresh option from the Viewport menu. To activate 
the Viewport menu, right-click the viewport title. The RefreshShade command replaces the 
render meshes on the selected objects. 

10 To get more localized control over the surface knots use the InsertKnot command (Edit menu: 
Control Points > Insert Knot) to add a row of points in the V-direction about half way between the 
bottom and the next row of points.  

 Knots can be added in the U- or V-direction or both with the InsertKnot command.  

 Wherever possible try to place new knots midway between the existing knot lines which are 
highlighted during the command. 
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11 Nudge these points a little to make a slight indention. 

  
 Keep the surface as simple as possible throughout. Add knots sparingly and only when needed; 

that is, make sure the big curves in the surface are satisfactory before adding knots to contend 
with the more local ones. Once knots are added it is much more work to edit and fair the long 
sweeping parts of the curves than with fewer knots. 

 When you are satisfied with the overall shape of the surface, you can add details to make a more 
finished object.  

 The surface can be offset and trimmed as in the first illustration.  

 Best results are obtained when the surface has at least degree 3 in both directions. This can be 
checked with Object Properties.  

 Note that offsetting surfaces generally results in a surface of one step lower in internal continuity. 
Surfaces that are only G1 internally may result in surfaces that have G0 continuity; that is, they 
may have a kink in them. Although Rhino allows these surfaces, this can lead to problems 
downstream. For this reason, if you intend to offset surfaces, it is best where possible to create 
the initial surface from degree 3 or higher curves. These surfaces have at least G2 continuity so 
that offsetting them will result in at least G1 continuous surfaces. Changing the degree of a 
surface that has been created from degree 2 curves to at least degree 3 in both directions is not 
sufficient to ensure a G2 surface. Simply changing the degree after the fact does not improve 
internal continuity. 

To make the offset surface: 

1 Change to the Cutting Curves layer. 

2 Draw a curve that represents where you want to split the surface. 
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3 Use the Offset command (Curve menu: Offset Curve) to make a duplicate of the curve. 

   
4 Use the Trim command (Edit menu: Trim) to trim the surface between the curves. 

  
 5 Use the OffsetSrf command (Surface menu: Offset Surface) to offset the surface. 

  
6 Delete the original surface. 
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7 Use the BlendSrf command (Surface menu: Blend Surface) to blend between the two surfaces. 

  
8 Add details if time allows. 
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11  Troubleshooting 
 

Some Rhino operations can make “bad objects” under certain circumstances. Bad objects may cause 
failure of commands, shade and render badly, and export incorrectly. 

It is good practice to use the Check (Analyze menu: Diagnostics > Check) or SelBadObjects 
(Analyze menu: Diagnostics > Select Bad Objects) commands frequently during modeling. If errors 
can be caught right away the objects can often be fixed more easily than if the bad part is used to 
make other objects.  

If the goal is to create a rendering or a polygon mesh object, some errors can safely be ignored so 
long as they do not get in the way of building the model itself in later stages.  

For objects which must be exported as NURBS to other applications such as engineering or 
manufacturing, it is best to eliminate all errors if possible.  

The troubleshooting tools are used mostly for repairing files imported from other programs.  

General strategy 
The troubleshooting steps will be the same, whether or not the file was created in Rhino or another 
application. Over time, you will discover patterns of problems and develop procedures to fix them. 

Although the techniques used vary greatly depending on the individual file, we will focus on a general 
strategy for repairing problem files  

Start with a clean file 
When possible, spending a little time in the originating application to export a “clean” file will save a 
great deal of clean up work later. Unfortunately, this is not always an option.  
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Guidelines for Repairing Files: 

1 Open the file. 

2 Hide or delete extra data. 

 Use the SelDup command (Edit menu: Select Objects > Duplicate Objects) to find duplicate 
entities and delete them or move them to a “duplicate” layer in case you need them later. 

3 Hide curves and points. 

 Use the SelSrf command (Edit menu: Select Objects > Surfaces) to select all the surfaces or the 
SelPolysrf command (Edit menu: Select Objects > Polysurfaces) to select all the polysurfaces, 
Invert (Edit menu: Select Objects > Invert) the selection, and move the selected items to 
another layer and turn it off. This will leave only surfaces or polysurfaces on the screen. 

4 Check for bad surfaces. 

 The Check and SelBadObjects commands will determine if some of the surfaces in the model 
have problems in their data structures. Move these surfaces to a “bad surfaces” layer for later 
clean up. If the bad object is a polysurface, explode the polysurface and use the SelBadObjects 
command again. 

5 Use ShadedViewport and visually inspect the model. 

 Does it look like you expected it would? Are there obviously missing surfaces? Do surfaces extend 
beyond where they should? The trimming curves needed to fix them may be on the “duplicate” 
layer. 

6 Look at the Absolute tolerance setting in the Document Properties dialog box on the Units 
page. 

 Is it reasonable? Free-form surface modeling requires an intelligent compromise in modeling 
tolerance. Curves are fitted to neighboring curves within the specified modeling tolerance. The 
tighter the tolerance, the more complex these curves become and system performance suffers. 
There is no point in calculating high density curve fitting to tolerance values that are not 
supported by your down-stream manufacturing processes or by the precision of the input data. 

7 Join (Edit menu: Join) the surfaces. 

 When joining, edges are joined if they fit within the specified modeling tolerance. If they are 
outside the tolerance, they are not joined. Joining does not alter the geometry. It only tags the 
edges as being close enough to be treated as coincident, then one edge is discarded.  

 Look at the results on the command line. Did you get as many polysurfaces as you thought you 
would? Sometimes there are double surfaces after importing an IGES file. Usually, one will be 
complete and the second one will be missing interior trims. When the Join happens, you have no 
control over which of the two surfaces it will select. If you suspect this has occurred, try joining 
two naked edges. If there is no nearby naked edge where one should be, Undo the join, and 
select for duplicate surfaces. Delete the less complete surfaces and try the Join again. 

 
Select Duplicates 

 
Select Bad Objects 
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8 Check for naked edges. 

 Naked edges are surface edges that aren’t joined to another surface. During the join process, the 
two edges were farther apart than the specified modeling tolerance. This may be from sloppy 
initial modeling, a misleading tolerance setting in the imported IGES file, or duplicate surfaces. If 
there are too many naked edges showing when you run the ShowEdges command (Analyze 
menu: Edge Tools > Show Edges), consider undoing the Join and relaxing the absolute tolerance. 
It is likely that the original modeling was done to a more relaxed tolerance and then exported to a 
tighter tolerance. 

Note: You can not improve the tolerance fitting between surfaces without substantial remodeling. 

9 Join naked edges or remodel. 

 The joining of naked edges can be a mixed blessing. It is a trade off and may cause problems 
down-stream. If your reason for joining the edges is for later import into a solid modeler as a 
solid, or a meshing operation like making an STL file, using the JoinEdge command (Analyze 
menu: Edge Tools > Join 2 Naked Edges) will not generally cause any problems. If you will be 
cutting sections and most other “curve harvesting” operations, the sections will have gaps as they 
cross edges that were joined outside of tolerance. The gap to be spanned is displayed prior to 
joining. If the gap is less than twice your tolerance setting, you can proceed without worry. If the 
gap is too wide, consider editing or rebuilding the surfaces to reduce the gap. Join and JoinEdge 
do not alter the surface geometry. They only tag edges as being coincident within the specified 
tolerance. 

10 Repair the bad surfaces 

 It’s best to repair one bad surface at a time, and Join them into the polysurface as you go. In 
order of least destructive method to most radical, the problems that caused them to fail Check 
can be repaired by the following: 

• Rebuild edges 

• Detach trim curves and re-trim 

• Rebuild surfaces (surfaces change shape) 

• Replace surfaces - harvest edges from surrounding surfaces, cut sections through bad surfaces 
and build replacement surfaces from the collected curves. 

 If a surface fails Check reporting that a tedge (trim edge) is not G1, this minor error can be 
ignored, or the multiple span surface can be split at the knots. 

 
Show Naked Edges 

 
Join 2 Naked Edges 
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11 Check for bad objects 

 Sometimes joining surfaces that pass check can result in a polysurface that fails check. Generally 
this is caused by tiny segments in the edge or trimming curves that are shorter than the modeling 
tolerance. Extract the adjoining surfaces, check them, use the MergeEdge command (Analyze 
menu: Edge Tools > Merge Edge) to eliminate these tiny segments, and join them back in. You 
are finished when you have a closed polysurface that passes Check and has no naked edges. As 
you are joining and fixing surfaces, it is generally a good idea to run Check from time to time as 
you work. 

12 Export 

 Now that the model has been cleaned up and repaired, you can export it as IGES, Parasolid, or 
STEP for import into your application. 

Exercise 20—Troubleshooting 

To try these procedures: 

  

 

1 Open the model Check 01.3dm 

 This file has a bad object. 

2 Open the file Check 02.igs. 

 This file has several problems. It is representative of commonly found problems with IGES files. 
After repairing the bad object and trimming it, look for other objects that don’t appear to be 
trimmed correctly. 

 

 
Merge Edge 

 
Check 
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12  Polygon Meshes from 
NURBS Objects 

 

Although Rhino is a NURBS modeler, some tools are included to create and edit polygon mesh objects.  

There is no best method that works for every situation. Downstream requirements are the most 
important considerations when determining which technique to use for meshing. If the mesh is going 
to be used for rendering, you will use different mesh settings than you would use for a mesh that will 
be used for manufacturing (machining or prototyping). 

When meshing for rendering, appearance and speed are the most important considerations. You 
should strive to achieve a mesh with as few polygons as possible to get the look you require. The 
polygon count will affect performance, but too few polygons might not give you the quality you are 
after in the final rendering. Generally if it looks good, then you have the right setting. 

Meshing for manufacturing is an entirely different situation. You should try to achieve the smallest 
deviation of the mesh from the NURBS surface. The mesh is an approximation of the NURBS surface 
and deviation from the NURBS surface may be visible in the final manufactured part. 
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Exercise 21—Meshing 
1 Open the model Meshing.3dm. 

2 Set the Perspective viewport to ShadedViewport mode and inspect the curved edge between 
the surfaces.  

 There is a series of angular gaps where the background color shows through.  

  
3 Press Esc to get back to a wireframe view.  

 The edges appear to be exactly coincident. The gaps you saw in the shaded view were due to the 
polygon mesh Rhino uses to create shaded and rendered views. The polygons are so coarse at the 
edges that they are clearly visible as individual facets. 

4 In the Document Properties dialog box, on the Mesh page, click Smooth & slower.  

5 Inspect the curved edge between the surfaces.  

 The overall rounded surface is smoother and cleaner looking but the edges still have gaps.  

  
 Although it is possible to use the Custom settings to refine the shaded mesh enough to eliminate 

the jagged edges, this will affect all render meshes in the model. This will increase the amount of 
time necessary to create meshes and may decrease the performance of shading and rendering to 
unacceptable levels. To eliminate the gaps without refining the mesh settings, join adjacent 
surfaces to each other. 
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6 Join the three surfaces together.  

 The mesh is refined along each side of the joined edges so that they match exactly across the 
edge. This eliminates the gaps visible earlier.  

  
 Rhino saves these polygon meshes with the file in order to reduce the time needed to shade the 

model when it is reopened. These meshes can be very large and can increase the file size 
considerably.  

7 From the File menu: Save Small. 

 This saves the file without the render meshes and the bitmap preview, to conserve disk file space.  

Note: The meshes created by Render and shading modes on NURBS surfaces and polysurfaces are 
invisible in wireframe display, not editable, and cannot be separated from the NURBS object. 
Render meshes are controlled by settings in the Document Properties dialog box, on the 
Mesh page. 

Creating polygon meshes 
The meshes created by the Mesh command are visible and editable, and separate from the NURBS 
objects they were created from. 

Rhino has two methods for controlling mesh density: Simple Controls or Detailed Controls. With 
Simple Controls a slider is used to roughly control the density and number of mesh polygons. With 
Detailed Controls you can change any of six settings and enable five check boxes to control the way 
the mesh is made.  

The mesh is created in three steps based on the detailed criteria: initial quads, refinement, and 
adjustment for trim boundaries. These steps are not shown to you, it’s all automatic. 

 
Save Small 
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In the following exercise we will discuss each of the six detailed controls and illustrate their influence 
on the model.  

Maximum angle - The maximum angle between adjacent faces in the mesh. Smaller values 
result in slower meshing, more accurate meshes, and higher polygon count. 

Maximum aspect ratio - The maximum ratio length to width of triangles/quads in the final mesh. 
Smaller values result in slower meshing and higher polygon count with more equilateral polygons.  

Minimum edge length - Bigger values result in faster meshing, less accurate meshes and lower 
polygon count. Controls the minimum length of the sides of quads and triangles of the mesh. 

Maximum edge length - Smaller values result in slower meshing and higher polygon count with 
more equally sized polygons. When Refine is selected, polygons are refined until all polygon 
edges are shorter than this value. This is also approximately the maximum edge length of the 
quads in the initial mesh grid.  

Maximum distance, edge to surface - Smaller values result in slower meshing, more accurate 
meshes, and higher polygon count. When Refine is selected, polygons are refined until the 
distance from a polygon edge midpoint to the NURBS surface is smaller than this value. This is 
also approximately the maximum distance from polygon edge midpoints to the NURBS surface in 
the initial mesh grid. 

Minimum initial grid quads - Bigger values result in slower meshing, more accurate meshes and 
higher polygon count with more evenly distributed polygons. 

To create a mesh using detailed controls: 

1 Select the object. 

2 Start the Mesh command (Tools menu: Polygon Mesh > From NURBS Object). 

 The Polygon Mesh Options dialog box appears. 

 

 
Mesh from NURBS object 
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3 In the Polygon Mesh Options dialog box, click Detailed Controls. 

 The Polygon Mesh Detailed Controls dialog box appears. These settings are saved in the 3dm 
file or template. 

  
4 In the Polygon Mesh Detailed Options dialog box set the following: 

 Check Refine. 

 Uncheck Jagged seams. 

 Uncheck Simple planes.  

 Uncheck Weld. 

 Click OK. 

 A mesh is created using the default settings. 

 
 

5 Hide the original polysurface and use the Flat Shade display mode to view the output. 

 The Flat Shade display mode shows what the model would look like if it was output for 
prototyping or machining at this mesh density.  

Flat Shade 
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6 Undo the previous operation, repeat the Mesh command, and then make the following changes in 
the Polygon Mesh Detailed Controls dialog box. 

 Note the changes in polygon count, the shape of the mesh, and the quality of the flat-shaded 
mesh. 

 
7 Undo the previous operation, repeat the Mesh command, and then make the following changes in 

the Polygon Mesh Detailed Controls dialog box. 

 Note the changes in polygon count, the shape of the mesh, and the quality of the flat-shaded 
mesh. 
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8 Undo the previous operation, repeat the Mesh command, and then make the following changes in 
the Polygon Mesh Detailed Controls dialog box. 

 Note the changes in polygon count, the shape of the mesh, and the quality of the flat-shaded 
mesh. 

 
9 Undo the previous operation, repeat the Mesh command, and then make the following changes in 

the Polygon Mesh Detailed Controls dialog box. 

 Note the changes in polygon count, the shape of the mesh, and the quality of the flat-shaded 
object. 

 
 





 

 

Part Three: 
Rendering 
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13  Rendering with Rhino
 

With Rhino, creating design renderings of Rhino models is easy. Simply add materials, lights, and 
render. 

There are several controls in the basic Rhino renderer that allow you to create some interesting 
special effects. 

In the following exercise we will render with and without isocurves, adjust colors, transparency, and 
ambient light to create images with special effects. 

Exercise 22—Rhino Rendering 
1 Open the model Finished Detergent Bottle.3dm. 

2 From the Render menu, click Current Renderer, then click Rhino. 

3 From the Render menu, click Properties. 

 The model has lights set up on a Lights layer that is turned off. 

4 In the Document Properties dialog box, on the Rhino Render page, check Use lights on 
layers that are off. 

5 Select the bottle and use the Properties command, on the Material page, to assign it a color and 
a glossy plastic reflective finish. 

6 Select the cap and use the Properties command, on the Material page, to assign it a color and a 
glossy plastic reflective finish. 
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7 Render the Perspective viewport. 

  

To render with isocurves displayed: 

1 Start the DocumentProperties command. 

2 In the Document Properties dialog box, on the Rhino Render page, check Render Curves and 
Isocurves. 

3 Render the Perspective viewport. 

 The wire color is the same as the layer color because the object's wire color is set to By Layer. 

 
4 Use the Properties command, on the Object page, to change the color to black, then Render 

the Perspective viewport. 

 The objects are rendered with black isocurves. 
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To render a transparent material with isocurves displayed: 

1 Use the Properties command, on the Material page, to change Transparency to 90, then 
Render the Perspective viewport. 

 The objects are rendered with black isocurves and the material is transparent. 

  
2 Use the Properties command, on the Object page, to change the Basic color to white, then 

Render the Perspective viewport. 

 The objects are rendered with white isocurves and the material is transparent. 

  
3 Use the Properties command, on the Material page, to change the Basic color to white. 

4 Start the DocumentProperties command. 

5 In the Document Properties dialog box, on the Rhino Render page, change the Ambient color 
to white, then Render the Perspective viewport. 

 The objects are rendered with white wires, but the wires on the back faces are a different tone. 

  
6 Experiment with these adjustments to get the desired effect. 

7 Turn on the Lights layer and adjust the properties of the lights for more subtle changes. 
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14  Rendering with Flamingo 
 

With Flamingo, creating presentation images of Rhino models is easy. Simply add materials, lights, 
environment, and render. 

With Flamingo’s powerful Material Editor, you can assign any combination of color, reflectivity, 
transparency, highlight, multiple bitmaps, and multiple procedural patterns to one material. 

In the following exercise we will add environment settings, add materials and lights, create custom 
materials, edit materials, add decals to objects, and render a scene. 

 

Exercise 23—Rendering 
� Open the model Mug.3dm. 

To set Flamingo as the current renderer: 

� From the Rhino Render menu, click Current Renderer, and then click Flamingo Raytrace. 
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To set up the rendering properties: 

 The rendering properties include environment settings, sun light, plant season, render, and 
ambient light settings. 

1 From the Raytrace menu, click Properties. 

2 In the Document Properties dialog box, on the Flamingo tab, click Environment to change 
how the background appears or to add certain special effects such as an infinite ground plane or 
haze. 

3 In the Environment dialog box, check Background Image, and select Jeff’s 
Sunroom_Big.jpg. 
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4 In the Background Image dialog box, change the Projection to Spherical, then click on the 
Main tab. 

  
5 In the Environment dialog box, Main tab, check Ground Plane. 
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6 In the Ground Plane tab, click Material, and from the Flamingo library select Ceramic Tile, 
Mosaic, Square 1”,_ Ivory,Medium Gloss, then click OK in all of the dialog boxes. 

  
7 From the Raytrace menu, click Render to render the Perspective viewport. 

To assign Flamingo materials to layers: 

1 Open the Edit Layers dialog box.  

2 In the Edit Layers dialog box, select the Floss Blister layer, and click in its Material column. 

3 In the Material Properties dialog box, under Assign By, click Plug-in to use Flamingo 
materials. 

4 Click Browse to access the Flamingo material libraries. 

5 From the Material Library dialog box, in the Mug library select Blister Plastic, and click OK. 

6 In the Material Properties dialog box, click OK. 

7 In the Edit Layers dialog box, click OK. 
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Add lights 
So far we have used the default lighting in Flamingo. This invisible light comes from over the viewer’s 
left shoulder. It is enough to illuminate the model and to give you a starting point. The default light is 
on only if no other lights are on in the scene and it cannot be modified. In order to control the lighting, 
we are going to add our own lights.  

To add lights: 

1 From the Render menu, click Create Spotlight. 

2 At the prompts, draw a large spotlight that shines on the scene from the front and slightly above 
as shown below. 

 Use elevator mode, or turn on the spotlight’s control points and drag them to move the light into 
position. 

 
Spotlight, perspective view. Spotlight, front view. Spotlight, right view. 
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3 Adjust the properties of the light as shown below: 

  
4 From the Raytrace menu, click Render. 

 This makes a nicer image, but two or three lights in a scene improve the rendering. We are going 
to add another light to create highlights on the mug. 

To add a second light: 

1 Select the first light. 

2 In the Top viewport, Mirror the light across the vertical axis. 

  
Spotlight, front view. 
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3 Adjust the properties of the light as shown below: 

  
4 From the Raytrace menu, click Render. 

To add a third light: 

1 From the Render menu, click Create Spotlight. 

2 At the prompts, draw a large spotlight that shines on the scene from the below. 

 This light will be used to add a little light to the underside of the toothpaste tube and the floss 
packet. 

  
Spotlight, front view. 
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3 Adjust the properties of the light as shown below: 

  
 It is important to turn the shadow intensity to 0 so that the light will penetrate through the ground 

plane. 

4 From the Raytrace menu, click Render. 

  

To make a material from scratch and assign it to a layer: 

1 Open the Edit Layers dialog box.  

2 In the Edit Layers dialog box, select the Mug layer, and click in the Material column. 

3 In the Material Properties dialog box, under Assign By, click Plug-in to use Flamingo. 
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4 Click Browse to access the Flamingo material libraries. 

5 In the Material Library dialog box, click Material, then click New, then click Default Gray. 

6 In the Material Editor dialog box, in the Procedures area, click New, then click Clear Finish to 
give the material a multi-layer finish. 

  
7 In the Material Editor dialog box, in the Procedures tree, select Clear Finish, and then change 

the Base Color to green (R=21, G=210, B=180).  
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8 Add some color to the Top Coat Mirror color (R=198, G=247, B=255) to add some realism. 

  
9 In the Material Editor dialog box, in the Procedures tree, highlight Base and move the 

Reflective Finish slider toward the middle or type in a value of 0.420. 

  



 

Notes: 

Robert McNeel & Associates ❑  177 

10 In the Material Editor dialog box, in the Procedures tree, highlight Top Coat.  

11 On the Highlight tab, check Specify Highlight, and change the Sharpness to 240 and the 
Intensity to 0.550. 

  
12 Save the material to the Mug Library. Name it Green Ceramic. 

13 In the Edit Layers dialog box, click OK to close all of the dialog boxes. 

14 From the Raytrace menu, click Render. 

  

Image and bump maps 
Instead of simply using color for your material you can use an image of a material. You can scan 
photographs and real objects like wallpaper and carpet, create patterns in a paint program, or use 
images from libraries of textures from other renderers, or other sources of bitmap images. 

Image mapping uses bitmap images to add detail to the material. You can use images to alter many 
attributes of the material’s surface including its color pattern and apparent three-dimensional surface 
quality (bump). Procedural bumps add a random roughness or knurled quality to the surface. 
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To create a new material with an image map and assign it to an object: 

1 Select the cap on the toothpaste tube. 

2 From the Edit menu, click Properties. 

3 On the Material tab, click Plug-in, and then click Browse to access the Flamingo material 
libraries. 

4 Select Flamingo/Plastics, White, Smooth to use as a template for the new material. 

5 In the Material Editor dialog box, on the Highlight tab, check Specify Highlight, adjust the 
Sharpness and Intensity. 
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6 In the Material Editor dialog box, on the Maps tab, under Image Mapping, click Add. 

  
7 In the Select Bitmap dialog box, select Tube Bump.jpg. 

 The Image Mapping dialog box appears. 

8 On the Main tab, click OK. 

9 In the Material Editor dialog box, click OK. 

10 In the Save Material As dialog box, save the material as Toothpaste Cap in the Mug material 
library. 

11 In the Material Library dialog box, click OK. 

12 In the Properties dialog box on the Flamingo page, in the Material mapping and tiling 
dropdown, select Cylindrical, then set the number of tiles and the height. 

  



 

Notes: 

Robert McNeel & Associates ❑  180 

13 On the Flamingo tab, click the Orientation button. 

14 Orient the mapping cylinder to the center of the cap, then adjust the position by moving the drag 
points to adjust it so that it roughly aligns with the cap. 

  
15 From the Render menu, click Render. 

  

Decals 
A decal is the method Flamingo uses to apply an image bitmap to a specific area of an object. 

The decal mapping type tells Flamingo how to project the decal onto your object. The four mapping 
types, planar, cylindrical, spherical, and UV, are described below. 

Planar  

The planar mapping type is the most common mapping type. It is appropriate when mapping to 
flat or gently curved objects.  

Cylindrical  

The cylindrical mapping type is useful for placing decals onto objects that curve in one direction, 
such as labels on wine bottles. 

The cylindrical projection maps the bitmap onto the mapping cylinder with the bitmap’s vertical 
axis along the cylinder’s axis, and the horizontal axis around the cylinder, like a wine bottle label. 
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Spherical  

The spherical mapping type is useful for placing images onto objects that curve in two directions. 
The spherical projection maps the bitmap onto the mapping sphere with the bitmap’s vertical 
axis (height), curving from pole to pole, and the horizontal axis curving around the equator.  

Initially the mapping sphere’s equator is assumed to be parallel to the current construction 
plane, and the sphere’s axis is parallel to the construction plane z-axis. Later you can modify its 
orientation. 

UV  

UV mapping stretches the image to fit the whole surface. The U- and V-directions of the surface 
determine which direction the map is applied. There are no controls. 

UV mapping works well for organic shapes, hair, skin, and plant structures.  

On some surfaces and polysurfaces, only parts of the image may appear in the rendering. UV 
mapping stretches the bitmap over the whole UV range of the surface. If some of that range has 
been trimmed away, the corresponding parts of the bitmap will not be visible. 

To map a decal with planar projection: 

1 Select the toothpaste box. 

2 From the Edit menu, click Object Properties. 

3 In the Properties dialog box, on the Decals page, click Add, select the Minty Green-Box 
Upper.jpg, then Open, and then click Planar and OK.  

4 At the prompts, using object snaps, pick locations for the decal Location (1), the Width (2), and 
Height (3) direction of the decal.  

 These three points define the decal plane’s location and extents. The decal plane must lie on or 
behind the surface of the object. The decal projects up from the decal plane. Portions of the 
surface that lie behind the decal plane will not show the decal. 

 After the decal is placed, you can click the control points on the decal control wireframe to move, 
rotate, or stretch the decal. 
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5 Press Enter or right-click to set the location.  

  
6 Continue to place bitmaps on the sides and ends of the box.  

 The flaps will require some additional controls. 

To add a planar decal with masking: 

1 Select the top end flap of the toothpaste box. 

2 From the Edit menu, click Object Properties. 

3 In the Properties dialog box, on the Decals page, click Add, select the Minty Green-
TopFlap.jpg, and then click Planar.  
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4 At the prompts, pick locations for the decal Location, the Width, and Height direction of the 
decal. 

5 In the Edit Decal dialog box, on the Map tab, in the Masking dropdown, click Color. 

 Use the dropper to select the black part of the image. Check the Transparent box. 

  
 The part that is black in the bitmap will appear as transparent in the rendered image. 

6 Continue to place bitmaps on the sides and ends of the flaps. 

7 From the Raytrace menu, click Render. 
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8 Use planar mapping to put the decals on the floss container and the toothpaste tube. 

 The magenta rectangles were created to assist with placement of the decals. 

  

To map a decal with cylindrical projection 

 The circle of the mapping cylinder is initially parallel to the current construction plane, and the 
cylinder’s axis is parallel to the construction plane z-axis. 

1 Select the mug. 

2 Start the Properties command (Edit menu: Object Properties...). 

3 In the Properties dialog box, on the Decals page, click Add. 

4 Select the Sailboat-002.jpg. 

5 In the Decal Mapping Style dialog box, click Cylindrical. 

6 At the prompts, pick locations for the Center of cylinder and a Radius or Diameter for the 
decal. 

 The controls then let you click the control points on the decal control wireframe to move, rotate, 
or stretch the decal cylinder.  
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7 Press Enter or right-click to set the location.  

 The Edit Decal dialog box appears, change the decal’s visual properties as indicated below. 

  
8 From the Raytrace menu, click Render. 

  
9 Turn on the toothbrush layers. 

10 Adjust the materials settings and lighting as needed to get the desired final results. 

  


